Vero tv has been crashing since one of the updates a while ago


I had been happily using my Vero tv for a while and it has been pretty much flawless until an update a had a while back, ever since my main problem has been that is freezes, normally when I come back after not using it for a while but it has happened once while streaming. another problem being that a couple of times when I click the directionals it would do it twice.
I have always used Ethernet connection since I got it, I did use cec but I have turned this off and now just use the vero controller. i did try turning on the wifi connection the other day and when I used the controller after that it would double or triple click and I struggled to get back onto wifi settings to turn it off.

the only problem I had in the passed was when I ran an update and didn’t have enough space but I resolved the issue and it was working fine after this.

Please could you help with this as before one of the updates i had it worked fine.

Thanx, Mat

How are you defining “crashing”? Could it be this case Vero black screen overnight - #4 by benjamin

thanks for your respose,
Sorry I think freezes is more the word I’m looking for, The screen shows whatever I was on last and only way to fix it is pull the power. not sure if the lan light flashes. maybe this is the same issue and I hope this will be fixed soon its damn anoying. Whats the deal with the wifi though, I was hoping to turn it on and start making use of air play?

Sorry I can not tell you anything on the Wifi but I am not sure which relation it has with Airplay. As long as the Vero is connected by Ethernet to the same LAN your Mac/Iphone/Ipad is connected to by Wifi then Airplay should work. Don’t require the Vero to be connected by Wifi

oh ok… thanks for your help.

Did you get this sorted bro?

I’ve got my Vero now and it seems awesome so probably best for you to reinstall OSMC on it.

Hmm have same issu here everthing freezes I can see the homescreen it froze the clock at 2:17 this night.
I got no addons and so on.

I have similar issues. Kodi freezes after a few hours, last time the clock on the screen had stopped at 02:30, had to restart via ssh.

Didn’t see anything on the Kodi log.

1 Like


If anyone would like to test then please run the following command via SSH:

wget -O- | sudo sh

With any luck, the freezes will be gone