Vero V and usb drive via SMB

Hey all,

is USB drive attached to Vero automatically shared via SMB or we need to add something to config?

I can see these folders, but not external drive that is in Media folder. Both on my pc and mobile.



Should be automatically shared.

Have you tried rebooting the PC and the Vero?

Sometimes that’s needed. I’d reboot Vero first.

1 Like

Your browsing \\[ip address]\osmc but an automounted and shared drive will show up in \\[ip address]\[mount name]

1 Like

I am browsing only \[ip address] and it shows osmc

Trying with mount name gives network error.

Is NTFS format a problem? Though I can see it in Kodi

No. I just checked it by formatting a drive as NTFS, copying a couple files to it and plugging it into my Vero V. It popped up as expected…

Had you unplugged and replugged the drive in since you installed SMB Server? Perhaps try safely removing the drive, unplug, reboot, and then plug the drive back in after Kodi fully loads and see if that gets you where you want to be.

1 Like

No, I just did a reboot few times.

Will try that, and also reinstalling smb in Kodi. Thanks for the pointer.

You mean My OSMC - App Store?

1 Like

Sorry, went to bed and then hectic Sunday.

Tried to unplug hdd and cycle power and reconnect, but that didint help.

Will try to reinstall SMB server(from app store) again when I have a chance.

I doubt that will change anything. If you know how to connect to the Vero via ssh we can give you some commands to check what’s going on.
Or even uploading logs via MyOSMC will give us some clues.

1 Like

Yeah, managed to sort NFS mount in the past so should be able to do some commands in SSH.

I am able to see “Backup” drive in SSH

Not sure if of any use?

It’s clearly not what’s causing the problem you created this thread to discuss; but once that’s fixed, it may not give you absolutely optimal performance. If the drive is going to be permanently attached to the Vero, then ext4 is probably the best format to use; if you also need to unplug it and plug it into a Windows device then exFAT might be a good choice.

1 Like

Ok please share URL from paste-log /etc/samba/smb.conf
Also URL from grab-logs -A
And what does ls -lah /media/BACKUP show?

1 Like

Does this mean I could change path to /media/Backup and it should work?


It would seem that having the drive named “Backup” causes a conflict and that is why it isn’t showing up. The easiest way to get this working would be to plug the drive back into Windows and rename it to something else (something like “Backup-Drive” should be fine).

Duh, never crossed my mind to try with different drive.

This worked!!! Thanks

1 Like

Glad to hear. I didn’t know it was an issue either until I spotted it in your logs. Just for reference for anyone else that stumbles across this thread it would seem that at present there is a limitation where a drive using the same name as a user on the system will not automatically share via samba. Notably, this means that a drive labeled as “backup”, “games”, or “osmc” will have this issue.

A fix is in the works, just have to check that there is no regression. And that might take some time, since it’s rather many things that can get effected when you mess with filesystem automation.

1 Like