VERO V. First thoughts 24 Hours in

I love my Vero 4. It’s my favourite gadget. Albeit I’m really not a gadget man. But it gets a lot of use and I must’ve owned my ‘4’ at least 5 years and never really experienced any issues with it. I use it really basically; no ‘library’ created, just a plugged in external hard drive to watch my old (space-saving) blu-ray rips. For a non-techie like me it works just fine.

And without meaning to sound like a kiss-ass, I think the after-sales service from Sam/OSMC is second-to-none. In fact, that’s the main reason why I’ve never even looked at an alternative media player and why it took me less than 2-minutes to order my Vero V after receiving a ‘presenting the new Vero V’ e-mail on Monday 6th November, which was apparently the launch day – as prior I knew nothing about such an upgraded release.

Now I didn’t need a new Vero. But I figured as mine is getting on a bit (the blue light on the front had mercifully stopped glowing a couple of years back) and as I rarely buy myself materialistic objects and as my Vero 4 does get a lot of use, and as I really like the look of the V’s design, I bought one without so much as a glance at a review. Schoolboy error…

So I’ve read from others about how impressed they are with the V’s speed; yet the 4 seemed to a layman like me, just as fast. Yes, it sometimes crashed. But guess what, the V has crashed twice already on me. The software layout is, bar a different colour palette, just the same as prior from what I can tell – except this time around I cannot get my own artwork to replace the folder icons if browsing ‘videos’ yet they do replace those icons when viewing ‘music’?!

Therefore just 24-hours after receiving the new Vero V I am incredibly underwhelmed and right now my only thought is, can I get my money back?

Not because it seems on the page, besides its nicer outward design, just the same as Vero 4, but because the biggest pain in the butt about this machine is the barely useable remote control!

When a remote control takes between 3-12 single clicks on one button to get something to do whatever it’s supposed to do, then surely that is a serious design flaw? It’s just painful to use. I cannot believe these have been released ‘as is’ when it seems this is a well-recognised problem.

I do not have a secondary remote or device to control the Vero, nor do I want one. Why should I? Why should I spend more money when the supplied remote should work, as the 4’s remote worked, like a dream! I’ve never encountered such an efficient remote as Veros 4’s. I could even bounce it off my sleeping cat in the other room and it’d still do what I wanted it to do with speed after a glorious one button click.

The Vero V is approximately 3-metres away from me, in a straight line; still appalling to use. I have tried a new battery, a re-pairing and made sure the clear cellophane has been removed from the front of the Vero, yet it’s still just useless!

I’ve read the issue is a built-in dongle on the V, yet an external dongle doesn’t seem to work. I’ve read a USB cable plugged into the Vero V interferes with the remote signal, yet as previously mentioned, I only use my Vero with a plugged in USB, so that is an issue. A major issue, for me.

So I didn’t need a new Vero, and now I’m thinking I really didn’t need a Vero V, as my Vero 4 was vastly superior. So why did I spend £150 on a device that is not entirely ready for general release, and can I get my money back on a return?

Perhaps when its issues, specifically the remote control are rectified, I’d try a second purchase.

It sounds like your use-case is well covered by Vero4k so the extra grunt of a V is not useful (?yet).

FWIW, you can use the external remote dongle from the vero 4k but only with the 4k’s remote. It won’t be compatible with the V’s remote.

There is an updated dongle that should be coming soon that should take care of the problems your experiencing.

As for the crashing, on the 4K or the V, this isn’t normal expected behavior at all. I would suggest to try to narrow down a bit what your seeing and start a new thread so we can help you address the problem. More specifically, when does it crash, is it repeatable, what exactly is connected, and can you supply logs from immediately after the crash. Are you using stock settings or did you transfer your userdata from your 4K. My first thought is that if you were seeing crashes on your 4K then perhaps there is a link such as a drive that draws too much current or damaged files.

As for the folder icons can you elaborate a bit more on the specifics of this setup? What skin are you using? Which screen view exactly is it that you are looking at and what is the file structure of a folder that isn’t working the same. A screenshot of your 4K from what you expect to see, and another from your V of what your seeing there, would be quite useful. Any view that is working on your old box can also work on your new box as it is the same Kodi. I’m sure it is just a matter of figuring out what setting needs to be changed.

Hi Mark,

It sounds like you didn’t necessarily need to upgrade your device. Your use case is quite simple, but not unique, as many Western Digital users started to adopt Vero as their playback device when their WD Live devices didn’t handle new codecs.

The device shouldn’t be crashing. If that happens again we can take a look at the issue and get it resolved for you.

Regarding the look and feel, it is identical to that of Vero 4K / 4K +. It sounds like you may have some customisations. If you update your Vero 4K / 4K+ to the latest software, you can make a backup of it and restore the exact setting to your Vero V. You can learn more about how to do that here:

The thing is – it’s not really a widely recognised problem. As I am sure you can imagine, we’ve shipped a lot of these since August, and only had a handful of complaints. The remote controller had to be redesigned in 2022 because the previous USB solution provider went bust. There were some range issues in sampling, but we addressed them in time for the production release.

The problem itself is USB3 and how it is implemented. It pollutes the 2.4Ghz spectrum and causes interference which can reduce the range of the keypresses. This is the very nature of USB3 and these issues have been reported on other devices as well like Raspberry Pi.

We have advised users of how to mitigate these steps (use a shielded cable when attaching USB3 peripherals); place the USB 3 device behind and at distance from the Vero V, etc. We’ve also actively working on some improvements which we should be able to make available shortly and I will keep users updated in that thread.

I’m assuming that your issue stems from the fact that your hard drive is plugged in to the USB3 port and is indeed itself, USB 3. You should be able to resolve your remote issues by relocating the hard drive to the black USB2 port temporarily. As Vero 4K / 4K+ only offered USB2.0 speeds, this is clearly sufficient for your needs. When we have a more resilient dongle to USB3 interference in a couple of weeks, you can then use this dongle and switch the USB hard drive back to the USB3 port in case you do want the faster speeds.

I hope this clears things up and gets things working as expected for you.

You can of course return the device in a like new condition for a refund within 14 days of receipt.



There is an updated dongle that should be coming soon that should take care of the problems your experiencing.

Well that will make a lot of difference, so I’ll be happy to bide my time on that one.

Maybe when I state ‘crashing’ my terminology is incorrect…?
What happens, usually when playing H265 video files that are 4K/HDR, if I skip forward a chapter then sometimes the video refuses to play and the whole system seems to ‘lock up’ and do nothing.
Could it be a response time to the WD external hard drive?

I’m attaching three photo’s so you can see the difference I am getting between Vero 4 and Vero V.
Hopefully they make sense, but ultimately it’s no big deal.

As stated in my ‘review’, your after-sales service is second-to-none. It’s rare. Very rare. Like blue steak.

If an upcoming dongle will help the remote control problem, which I can’t believe isn’t affecting more users, then I’ll happily wait it out.

You’ve made some helpful and interesting comments, Sam that may fix some of my issues.

Ultimately I want to love the V as much as the 4! So I’m not ready to split up just yet. With a little counselling this partnership can be a beautiful long-term thing.

Many thanks (all respondees) for the replies.

As this one is related to the OSMC Skin, I can comment… The screenshots you’re showing are from completely different skin versions and even Kodi versions - your Vero 4K still seems to be running Kodi v19 or even older and the V is obviously running the latest and greatest.

As the skin code related to the images in questions have not changed even longer than how old you Vero 4K skin version is, I’m not quite sure what the cause for this could be. It could be a number of things, including Kodi feeding these images to the skin in a different fashion in newer Kodi versions…

I am going to thank you Chillbo for your comment - but admittedly it means nothing to me!

I am one of the least technically minded people you could talk to… The Vero 4 got regularly updated whenever new updates were available, and that’s all I know.

You state V is the latest (true) and greatest (yet won’t connect/replace my artwork to replace the folder icon) so not really greater at all, for me - accepting that it may be my misunderstanding of the whole set up.

I have looked at switching to ‘Estuary’ but suppose I’ve gotten use to ‘my layout’ (as in how it pretty much came out of the box) and as far as add-ons, such as the database that will allegedly add film posters, presumably instead of random image thumbnails, this does nothing.

I’ve tested folder posters using a couple different naming schemes in the OSMC skins Videos view on a source that hasn’t been scraped and I can’t seem to get it to display any way other than exactly as I expected. The posters show up for me perfectly.

What exactly is the file name of that artwork in the “1990’s Films” folder shown in your screenshot? Can you reboot twice and then upload logs with the My OSMC add-on and post the url in this thread so I can see how you have your system configured.

And can I ask why you have decided to just use file browsing instead of creating a library? Kodi’s wiki has pretty decent instructions of how to set one up and it probably sounds a lot more complicated than it really is.

As for the locking up on certain files we would need more details on exactly what these files are (mediainfo, are these rips you made yourself or acquired from the interwebs), and preferably debug logs when this happens. Does pressing stop bring you back to the UI or do you have to hard reboot? Is this random or can you reproduce crashes on certain files? It is possible that it could be the drive itself as well since you said this was happening on both Vero’s and I’m assuming your using the same drive on both? If you have another drive laying around you might try using that instead for a bit to see if the problem is the same when you take that other drive out of the equasion.

It definitely will.

Hopefully there are also some other mitigation steps you can use in the interim as suggested previously.

Mark – can you got to My OSMC on the Vero 4K + and let us know the OSMC version in the bottom left corner. This would be useful


Blockquote And can I ask why you have decided to just use file browsing instead of creating a library?

I have tried to create a nicer looking library, and got absolutely nowhere with it.
To me, Kodi’s wiki is not straight forward.
I can barely turn my computer on, I am that technically inept.

The whole point of me getting the Vero was to free up all the space my DVD/blu-ray physical collection once took up and condense it into a small hard-drive. That’s all I really want it for, to watch the films from time-to-time.

Creating a nice looking library with film posters et all may be quite cool, but as I am more at ease chopping up wood it’s something I can leave/live without.

But thank you for your time and suggestions.

Hello there
Great to know - is there an ETA on this? To be honest I’d rather wait for the updated dongle before carrying out an order. Thanks

Instead of making my own thread about the same topic, Ill share my first experience with it as well.

Moving around the menu options over NFS is definitely a lot snappier. Personally I was hoping for a slightly new/updated skin but fair enough I can always change from default.

Initially pass through was not working but then I remember this from the setup of the previous some years ago and had to enable advanced options and then enable each codec type, that could generate unnecessary support queries.

Adding NFS shares worked first time for me didn’t need to configure wired network or do anything custom, just browse share add done.

So far no issues found for me but I only use it for watching stuff over NFS. :slight_smile:

We won’t be shipping an updated dongle per se. We will just be making an additional dongle available on the store at cost price for those that require one. So far – this should be very few, otherwise we’d include it as standard in the box. You likely won’t experience an issue at all – particularly if you don’t intend to attach any USB3 storage device to the USB3 port.

We are just evaluating that they work as expected and do improve performance. We also recently added support to disable the internal receiver when one is plugged in so they don’t ’fight’ each other during the pairing process and cause conflicts.

It’s also worth considering that the current price is introductory — so if you do plan to order a Vero V, now is the best time.



Glad you are finding things snappier.

You can restore your complete environment from your Vero 4K / 4K+ as long as it’s up to date. This might make things easier.

We’ve not made significant changes to the skin and we’ve kept the software stack the same as Vero 4K / 4K+ for compatibility and familiarity.

Enjoy, and any issues, do let us know

Skins in Kodi don’t really work like that. I understand that there are plenty of electronic devices that when a new model comes there are also UI changes, but Kodi’s software and its add-ons are in a continued state of change and updates. Both Estuary and the OSMC skin (the two skins OSMC ships with) have seen updates in the last year. It is a good thing that someone running on five year old hardware gets the same updates that someone is getting with the most up to date hardware. If there is a particular feature that you would like to see in the OSMC skin there is a feature request section of the forum.