Vero V going into standby

Hello, my new Vero V is going into Standby in strange ways. Allow me to explain.
When I’m watching video files from a USB drive, the Vero will go into Standby mode after exactly 4 minutes 40 seconds of playback of a new file.
It’s not relative to when I last pressed a button on the remote. It is only relative to when I started to play the content (skipping forward and backward in the video makes no difference).

I’ve reproduced it many times, always exactly 4mins 40 secs. I reproduced it this morning and wrote down the time of my inputs:
10:22:55 - Selected a H.264 file to play from my USB 3.0 drive.
10:23:27 - Turned on subtitles
10:23:50 - Pressed Back on the remote (did not touch remote from this moment on)
10:26:45 - System suddenly goes into Standby. (picture disappears, Vero standby LED comes on, TV reports No Signal message)
10:27:10 - I press a button on the remote to wake up the Vero.
At this point, the GUI has reset to the file browser screen, so I have to select the video file again and turn on subtitles again, which is a bother.

Relevant snippet from the logs:
2024-03-22 10:23:27.902 T:26455 info : CDVDSubtitlesLibass: Creating new ASS track
2024-03-22 10:26:43.164 T:2846 info : Activating standby mode
2024-03-22 10:26:43.165 T:2846 info : Activating Vero standby mode

Full logs:

The weirdest thing is that if I now play the video after waking up the device again, I will be able to watch it for hours with no issues. The issue only appears when playing the first file of the day. If I rewatch this file from the beginning, the issue will not appear. If I choose a new file from the same USB drive, the issue will not appear.

If I turn off my TV, the Vero goes into Standby. If then wait a day and select any video file the next day, the issue will appear once again and the cycle continues.

I’m using the Vero V (just arrived 7 days ago)
OSMC Version: February 2024 2024.02-1
I updated to the latest version as soon as I got it out of the box, so not sure if this is a new version thing.

Things I’ve tried:
Turning off the Power Save entirely (this was set to Dim after 3 minutes by default) - Issue still present
Trying with and without subtitles - Issue still present
Playing H.265 content - Issue still present
Pressing Vero remote buttons constantly to try and keep the Vero awake - Issue still present
I don’t have CEC enabled at all, but even so, I tried constantly pressing buttons on the remotes for my TV and my sound system to see if they were sending a Sleep message to the Vero somehow, but it made no difference.

I can see in the logs that it’s choosing to go into standby rather gracefully, with no errors or messages in the minute leading up to the standby message. Can anyone help me out?

Thank you.

I couldn’t spot the trigger either but I think it may be helpful to try to isolate it a bit further if feasible. By this I mean trying things such as…

Unplugging all devices so it is just the Vero and the TV and see if the issue stops. This may help finding an issue where there is a different CEC enabled device that is interacting in an odd manor.

Stopping Kodi and renaming the ~/.kodi folder then restarting Kodi to get full default userdata and see if it still does it this way. This should isolate out any Kodi settings, add-on interactions, etc.

Try it on a different display as see if the behavior follows the Vero. If the behavior doesn’t follow then maybe there is some kind of sleep setting or similar on the original display that could be looked into.

Make sure you don’t have a timer on by accident