Vero V has no output on monitor

I have just received my Vero V to replace the setup with osmc on a RPi3.

When booting up the Vero V, the monitor complains about an unsupported resolution. With the old setup, there are no problems with the monitor resolution (1280x1024 and 60 Hz).

I first see a splash screen (bios?), followed by some kernel lines. From that moment on, the monitor complains about an unsupported resolution.

Trying on another monitor, everything works.

How can I have something shown on the dedicated monitor?

What have I tried so far:

  • set the resolution to 1280x1024 in the GUI and reboot
  • set the resolution using fw_setenv
    • sudo fw_setenv hdmimode 1280p
    • sudo fw_setenv hdmimode 1280x1024p60hz
      of course same setting for outputmode and followed this with a reboot

This is the output of /sys/class/amhdmitx/amhdmitx0/disp_cap


The monitor is a Samsung SyncMaster 193T (I know, I know, very old stuff) and connected to the HDMI port via a HDMI to DVI convertor.

Logs are available on

That’s interesting. I had a reason to connect a Vero to my DVI-only monitor last week (first time ever) and also got a blank screen.

In your log it says
[ 8.863552] hdmitx: video: Sink is HDMI device

I suspect it should say DVI device but we’ll need to find out why that should make a difference.

Meanwhile, if you have a HDMI-VGA converter can you try that? That always worked for me on a 1280x1024 LG monitor.

We’ve got a fix for this. I’ll ask @sam_nazarko to build it so you can test it.


I have looked around but no, there isn’t one in the house.

Nice, I’ll certainly do that.

I’ve merged @grahamh’s fix and will make testing available shortly but we want to get a couple more fixes in


Hello @sam_nazarko ,

is the fix available for testing?

Since it would the first time I would test for OSMC, is there a page that describes how to install the merged software?

The fix is available but we have some changes to deinterlacing that are not fully stable yet, so I would advise that you wait.


What are those, then?


Thanks for your email today outlining that you are still experiencing a problem with this. We hope to solve the issue with deinterlacing shortly, but for now I suggest you update and confirm your display now works as expected.

I’d appreciate it if you could test this. To test:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Thanks Sam,

with the update from the staging repository, the monitor is working.

Great work.

1 Like

I’m glad to hear this.

Sorry for the inconvenience and thanks for taking the time to test and confirm this.

We’ll have this in a stable update shortly, but we’re working out a few other issues first before we do another release.