Vero V missing keypresses & pairing other osmc remote

Same thing here also. Missing key presses. Vero is on open shelf under 2 meters away, surrounded by other devices. Fortunately this is not a problem for me as I’m using a Harmony remote.

I wonder, has the transmit power of the OSMC remote been reduced in this latest version ?

No, but we had to change USB solution provider as the former one went bust.

So are the keypresses being lost/missed during the processing (interrupt handling) of the USB data, at the (internal) dongle or the onboard USB interface ?

If they are, then surely there’s a potential SW solution (or firmware in the dongle) ?

The USB dongle is subject to USB3 interfence.

We are working on a solution, but there’s not much we can do in software.


Intel has published an article about USB3 interference and 2.4gHz devices. It seems to be a known problem since the arrival of USB3.

A (really ugly) workaround would be to use a short USB3 extension cable to move the device further away from the Vero V. I solved my problem by moving the USB backup stick to the USB2 port and I replaced it with a version with a metallic housing.

Same problem happens on my PC: as soon as I insert an USB stick in my hub next to the mouse receiver it becomes nearly unusable.

We are indeed aware of that article. We will have some mitigation methods for affected users shortly.


1 Like

The USB 3 extension cable can be a bit hit and miss. For example I found with a USB C SSD I have the supplied short A-C cable had bad interference and sticking a 30 cm USB 3 A-A extension did relatively little. Swapping the extension to the same cable in a 1 m variant did better, but huge improvements were found with a USB 3.1 A-C cable (male to male, not an extension) with either 30 cm or 1 m versions. All these cables were all new and of the same style and manufacturer. Swapping the cable that comes with a WD My Book does little to nothing for the remote. Those don’t seem to interfere too much but the placement to the drive itself with that one seems to have a much larger impact.

I don’t know about “ugly” though. I think my red braided cables are rather attractive and repositioning a USB port to hide a drive can be a good thing. :grin: For those doing sneakernet an extension can both improve accessibility and save wear and tear on the USB port of the device itself.

How about providing an option to allow the USB3 interface to be enabled/disabled thereby potentially reducing interference with the remote dongle RF frequencies.
(i.e. turn off its clock, disable the interface, or something similar).

This would be a good solution for those that dont need to use the USB3 interface.

The simplest way to do that is to just not connect a USB3 device to the USB3 port, or if you wish to use a USB3 device, use the USB2 port.

In a few weeks we can provide an external dongle at cost for anyone that wants an increased range or experiences interference.

Fortunately from the number of units shipped it does look like only a few users are having an issue.


From my experience with this issue, I still had the same problem without anything connected to the USB3 socket.

Changing to the older Vero4k+ dongle/remote in a USB2 socket resolved the issue.

I would like to rely on the improved performances of the USB 3.0 port so, if I’m going to experience the same issue mentioned in this thread (I received my units right now), then I’ll go for the Vero 4K+ remote with its own dongle plugged in the USB 2.0 port.
Not a big issue for me since I would not use the USB 2.0 port for any other service.

The difference is in the dongle. The environmental difference between being internal and plugged into the USB port on the side of the unit isn’t significant. The interference that comes from USB 3 is from the frequency of its communication. This high speed communication doesn’t happen until It sees a USB 3 device and starts talking to it.

I just tried my new Vero V with the provided remote and apart a couple of times where I found it non responsive, I have to say that the experience is almost positive.
I did the tests with a 4TB 2.5" drive hooked-up to a powered USB 3.0 hub connected to the USB 3.0 port of Vero V.
Watched a couple of episodes of The Witcher in 4K with several start, stop, pause, FF, REW commands at a distance of a couple of meters from Vero V.

It’s not going to affect everyone. But for those that experience a problem we will have a solution


Sorry, but I don’t fully understand your response in the context of my comment.

Sure, I understand that if the dongle is internal/external this will make little difference to performance and yes the USB3 frequency of data tx/rx can potentially interfere with the remote/dongle frequencies.

My issue was that I HAD NOTHING CONNECTED TO THE USB3 external port at the time and therefore no USB3 communication was occuring… yet I was still noticing missing key strokes (e.g. continuous down arrow browsing through media files), which seems to suggest there was some other problem.

My solution was to use my extant Vero4K+ dongle and remote and the problem went away.

I would really like to understand the physical/electronic differences between the two versions of the remote shipped with the ‘4K+’ and ‘V’.


So would we :confused:. This remote was shipping with late Vero 4k+s and performed well, but it does seem more sensitive to 2.4GHz noise than older remotes. I find it works acceptably from where I sit 3-4metres away with my USB3 HDD plugged in, but the window on the front of the V needs to be facing me with line-of-sight. (The internal dongle is behind that window.)

1 Like

You had queried about disabling the USB 3 interface. I was attempting to convey that the broadband noise it can create that can interfere with the remote does not happen until a USB 3 device is attached to the USB 3 port with a USB 3 cable. The current model dongle is more sensitive to interference more broadly as well from other external factors vs the old model remote. It is something Sam has been working on improving for some time and I’m sure he will post an update when he has something to share.

Thank you @darwindesign

1 Like

Just passing on that I am also finding that the Vero V remote is missing button presses on a regular basis. I am interested in any dongle solution so will keep my eyes peeled - it’s just not as flawless as it was with the Vero 4k+. All good apart from that though.

1 Like