Vero V not broadcasting itself via SMB WINS?

This is a very minor thing, but prior to upgrading from my Vero 4K+ to my Vero V, I had no issues with the Vero broadcasting itself as an SMB share using it’s device name (vero).

I did a backup and reinstall to migrate to the Vero V and everything seems to be working exactly the same except I just can’t get it recognized/broadcasting via SMB. I can access it via it’s IP address so the samba server and shares are up and going - I just can’t see it as a device in windows network browser using it’s WINS name. My router is working as a WINS server as well.

What could I be missing from the configuration?

Can you check which OSMC version you have on each device?

Logs from each device would be even more useful


Forget Windows network browser and just open Windows Explorer and in the address bar type in two backslashes and then either the device name or IP address and hit enter (ie \\verov or \\ Do note that the device name is going to be what was set during the initial walkthough and if you change the name later in Kodi’s services settings that is only the name for Kodi and not the OS. Once you have to share open in Explorer you can Pin it, make a shortcut on your desktop, or map it to a drive letting from the context menu. Any of which are less clunky than keep going though the slow network browsing window.

SOLVED - but not entirely sure how/why…

@darwindesign sorry I forgot to mention in my post that I was using explorer and \\vero was what I was doing and that wasn’t working, but doing \\192.168.x.x was working.

@sam_nazarko I noticed that the ws-discovery option was disabled so I turned that on and then I have done several reboots of my router that is acting as a WINS server and manually changed the name of the device again in the KODI settings screen followed by multiple reboots and it now seems to be working.

Could it have been the ws-discovery option being off? I thought that would only affect vero/kodi’s ability to browse folders and if every setting moved over when I migrated, I would presume that was off on my Vero4k.

Right now the 4K has been moved over to family member’s house so I can’t check and test remotely with ease.

SMB is a dreadful protocol, but it’s still convenient in secured home environment if you Windows is your primary computer platform…but it is, and always has been, quirky / glitchy

Could be. I think it works by devices keeping a list of other devices that announced themselves. If discovery is off then that announcement isn’t going to happen I believe. I’ve not had it be a problem on my network but if push comes to shove and you really want to use the device name an option would be to make the IP of the player static and add an entry to Windows host file so discovery would be moot.

Thanks for the feedback. I will check to see if we can improve things without a trade off with regards to security


Just my 2 cents, even if marked as solved.

This isn’t an official solution, but I’ve have worked with it for over a year. I can say that it can be problematic if you don have stable ip# on your machines, I’ve reserved all my Linux machines in the router. Which all use this service:


# Setup configure and autostart wsdd service, to announce the machine on windows network
sudo apt install ./wsdd_0.7.0-2.1_all.deb
echo "WSDD_PARAMS=\"--interface "$(ip route get | awk -- '{printf $5}')" -4\"" > ./wsdd.conf
sudo cp ./wsdd.conf /etc
sudo systemctl enable wsdd.service
sudo systemctl start wsdd.service