Vero V OSMC installer - Segmentation fault

This is the first time I was reinstalling Vero V from scratch.
I booted up from the SD Card, waited for the 60 seconds timer to pass until installation started. The progress bar was moving until the installation eventually stopped with Segmentation fault.
Is there anything I can do to investigate what failed and hopefully fix the issue?


I found the following log on the SD Card afterwards:

Wed Jan 1 00:00:10 2020 Starting OSMC installer
Wed Jan 1 00:00:11 2020 Detecting device we are running on
Wed Jan 1 00:00:11 2020 Mounting boot filesystem
Wed Jan 1 00:00:11 2020 Trying to mount to MNT_BOOT (/mnt/boot)
Wed Jan 1 00:00:11 2020 Using device->boot: /dev/mmcblk1p1 and FS: fat32
Wed Jan 1 00:00:11 2020 Filesystem defined by /mnt/boot/filesystem.tar.xz
Wed Jan 1 00:00:11 2020 No preseed file was found
Wed Jan 1 00:01:14 2020 Creating root partition
Wed Jan 1 00:01:14 2020 Calling fmtpart for partition /dev/osmcroot and fstype ext4
Wed Jan 1 00:01:15 2020 Creating filesystem with 7494656 4k blocks and 1875968 inodes
Filesystem UUID: b7ce4aaf-ddf0-4492-a4b4-d76bde6ac209
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 

Allocating group tables:   0/229       done                            
Writing inode tables:   0/229       done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information:   0/229       done

Wed Jan 1 00:01:15 2020 From a root partition of /dev/osmcroot, I have deduced a base device of /dev/osmcroo
Wed Jan 1 00:01:15 2020 Mounting root
Wed Jan 1 00:01:15 2020 Trying to mount to MNT_ROOT (/mnt/root)
Wed Jan 1 00:01:15 2020 Using device->root: /dev/osmcroot
Wed Jan 1 00:01:15 2020 Extracting files to root filesystem
Wed Jan 1 00:01:15 2020 Starting extract process ...
Wed Jan 1 00:01:15 2020 Extracting from /mnt/boot/filesystem.tar.xz
Wed Jan 1 00:01:23 2020 Halting Install. Error message was: Segmentation fault
Wed Jan 1 00:01:23 2020 Extraction of root filesystem completed
Wed Jan 1 00:01:23 2020 Configuring bootloader
Wed Jan 1 00:01:23 2020 Configuring bootloader: moving /boot to appropriate boot partition
Wed Jan 1 00:01:24 2020 Vero V family: bootloader to be flashed is
Wed Jan 1 00:01:24 2020 Configuring boot cmdline
Wed Jan 1 00:01:24 2020 Configuring /etc/fstab
Wed Jan 1 00:01:24 2020 Successful installation. Dumping log and rebooting system

Try another installation media - it can happen with a corrupt card.

Also re-download the image when prompted

Hmm, thank you for the advice. Unfortunately, this did not help me.

I just tried and the boot from USB also ended with a segmentation fault on the same step, just 2 seconds later.
I tried both of the public builds with both SD card and USB now. All the attempts failed :frowning:

Did you re-download the OSMC installer?
Which version of OSMC are you trying to reinstall?

From your log, it actually looks like the reinstallation is successful.
Does the system boot?

The system does not boot. I tried 2023.12-1 and 2023.08-1, both from usb and sd card and each time downloaded the distribution from scratch. No success, segmentation fault each time.

When you now reboot do you see anything on the screen? Can you take a picture?

There was another user that reported this. We couldn’t chase it down – but then suddenly he said it was fine.

Since then he’s been fine.

But as @fzinken is saying – are you actually able to boot in to OSMC after this? The installer log is reporting a successful install after removing the installation media.

Might also help to know what prompted a reinstall


This is the state after I try to boot:

Might also help to know what prompted a reinstall

After playing with the hardware for a few weeks, both with the plugins and directly on the box. Two or three days ago, I started to tinker with the SponsorBlock plugin for YouTube. Eventually, I decided that what I have on the system is a big mess, and maybe I should just start fresh.

What is behind that black console window?

Haha, thats a wall, i thought i would take a zoomed in picture.

There is another way to reinstall OSMC with a low level format.
I will prepare something.

1 Like

You should download this file:

And use it as a ‘local image’ in the OSMC installer and write it to either USB or SD card. When the process is completed, the drive should show up with only two files:

  • aml_sdc_burn_osmc.ini
  • upgrade.img

If this is the case, the install media has been imaged correctly.

Now apply the USB or SD card to the device with the power off

Take a non-conductive pin and apply it to the device’s 3.5mm out when applying power (you might need a spare hand for this). You should hear a soft, audible click. Hold that in and count to ten, then release the pin.

You won’t see anything on the screen. If your USB stick has an activity light, you should see it is being read from.

After a couple of minutes, the Vero V’s blue LED should blink on and off indefinitely. This means that the device has been reformatted. It’s now safe to remove the USB/SD card and re-apply power.

The segfault issue is pretty weird. I had another user experienced this, then he tried on another machine and it just works. I suspect there will be a bug somewhere that I will need to track down. For now, this should get you up and running.

Sorry I am clueless about the pin, can you explain it like for a stupid person I am? Where should I put the pin? Should the power be on/off during that time?

  1. Disconnect power to the Vero
  2. Put a non conduction pin (e.g. Toothpick) into the headphone socket of the Vero (the small round socket) till you hear a click
  3. While holding the pin connect power to the Vero and count till 10.

I am sorry I did not manage to successfully do the second type of installation. I attempted many times, but regardless of what I seam to do, the hardware boots into the mode i sent a screenshot of earlier.

The first type of installation still fails with segmentation fault.

I ordered a new instance of the Vero V. I am happy to send this one to anyone more capable than me for further investigation.

I believe @sam_nazarko can get you going with this.

Do you have a USB-A cable? You could then restore it via PC.

Alternatively contact with the order number and I will sort this out myself for you

A screenshot of the contents of the USB/SD would also help.