Vero V: Skin "AEON MQ9" installation not possible

I need your help please.
I wanted to install the skin “AEON MQ9” on my new Vero V.
But it does not work.
Since one hour I see: “AEON MQ9 installation screen: Do not press any button. Wait until the process is complete”.
That’s not normal, is it?
How can I undo this?
Thank you very much for your help.

Have you checked if this skin is supported with Kodi v20?

I don’t know anything specific about this skin but I would first just power cycle and see if it starts up then. Failing that then there is a few options to get back to a working skin. If you have web access setup then you can use that to your skin (at least you can with the default Chorus 2 interface). Failing that then I would ssh into your box and

systemctl stop mediacenter
nano ~/.kodi/userdata/guisettings.xml

A few lines down you will find the line you can modify to read…
<setting id="">skin.estuary</setting>

then ctrl+x, then Y, then enter, to save the file and exit nano. You can then start Kodi back up with…
systemctl start mediacenter

It’s listed in the Nexus repository, so it should, in theory, work on Kodi 20.

Some of the more advanced skins use skin helper services, and it sounds like one of those get stuck. If the skin won’t load and you can’t change back, I think if you rename the guisettings.xml file in ~/.kodi/userdata and restart that should get you the default skin back. I’d delete any settings in ~/.kodi/userdata/addon_data/skin.aeonmq9 and then try changing to the skin again. Maybe it’ll get itself unstuck.

1 Like

Sorry, no. :frowning:
Is there an easy way to reset the Vero V to factory settings?

I have not yet set up web access.
I have no knowledge of SSH.
Does it work with Putty?
What would be the correct SSH port?
Is there an SSH user and password?
Sorry, is there a description for beginners?

Where can I delete these files?
I do not have access to the Vero V.

Many thanks for your help.

If you wanted to do a full install you can follow the download link at the top of the site. If you just wanted to reset Kodi’s userdata…

How to restore Kodi defaults

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

His comment was to delete the file I suggested to modify. I don’t see the point of doing this as the edit is almost as easy without losing all your other Kodi settings.

Thanks a lot @darwindesign , your instructions worked well.
I use for SSH:
username: osmc
password: osmc
and SSH Port it is 22.

1 Like

Could you please kindly check why the skin “AEON MQ9” can’t be installed?

I’m not able to install this skin on any of my Kodi instances, OSMC or otherwise. Since this issue doesn’t seem limited to OSMC or the Veros, you’re probably best off posting something here:

For me Aeon Nox Silvo works fine and I have testet MQ9 , it’s a little bit slower, but works on my Vero V .Aeon Nox Silvo for me is the better solution.

I think you should check with the developer of this skin directly

Hi all… I also installed AEON MQ9 on my Vero V and used for a few days…

I had the same behavior while installing it and was baffled at first… after a fair amount of time waiting I assumed nothing was going on behind the scene and pushed “back” a few times…

After maybe 9-10 “back” key presses, the percentage of menu setup/build-up’s completion appeared and install completed.

Later I checked online and found on the (LONG!) official skin’s thread that other users, on several platforms, experienced same behavior…

So, this may work for you too.

FWIW, I used the skin for a while, but I found it too slow on the Vero V (Too complex?) and also started to find it too heavily overcharged, graphically.

I reverted to another skin I’ve become a fan of, and that’s Arctic Horizon 2… Much cleaner, much smoother and just perfect in my opinion… also, well maintained and with the right amount of bells’n’whistles. Works fine even in Kodi installed on my Philips Android TV, and this should tell something.
Good Luck!

1 Like

It happened to me too.
at first I took off the power from the vero V, then I tried installing it again with the same results, but this time I pressed the back button on the remote two or three times (even though on the screen was written to not press any button) and suddently a progress bar appeared and the operation finished succesfully.