Vero V wifi problem


I purchased a new Vero V today to replace the Vero 4k+ I’ve had since 2019 and it’s an absolutely great device. I did a clean install of 2023.08-1, but I’m having a problem playing 4K HDR videos over wifi (5Ghz) where the device freezes completely. However, the original Vero 4k+ has no problem with the same video in the same place and there doesn’t seem to be a problem on the cable either.
The only thing that helps after the freeze is to unplug the device.

If that helps, the log is here:

Thanks so much for the help.

And if you disable that Cinema 2 add-on you installed that is throwing python errors?

I’m not 100% sure because I’ve only done a few experiments so far, but it looks like the Vero V has some problem with the 80 MHz channel bandwidth. When I change the channel bandwidth to 20 MHz or 40 Mhz on my ASUS RT-AX55 router, the problem does not appear.


I can see the WiFi adapter is working OK from logs

Can you try a fresh install from Download - OSMC and check if you can connect and watch videos without issue?



Suggest to always test with iperf3 then you do not depend on any Kodi components

Hi Sam,

it is clean install through usb flash drive and image 2023.08-1.

Best regards


I tried iperf
with the bandwidth set to 80 MHz on the router

right after the movie starts, the vero freezes and disconnects from wifi, sometimes it takes a little longer

[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 18.8 MBytes 157 Mbits/sec
[ 5] 1.00-2.00 sec 20.6 MBytes 173 Mbits/sec
[ 5] 2.00-3.00 sec 20.9 MBytes 175 Mbits/sec
[ 5] 3.00-4.00 sec 21.0 MBytes 176 Mbits/sec
[ 5] 4.00-5.00 sec 20.7 MBytes 174 Mbits/sec
[ 5] 5.00-6.00 sec 21.3 MBytes 178 Mbits/sec
[ 5] 6.00-7.00 sec 20.8 MBytes 174 Mbits/sec
[ 5] 7.00-8.00 sec 20.6 MBytes 173 Mbits/sec
[ 5] 8.00-9.00 sec 19.7 MBytes 166 Mbits/sec
[ 5] 9.00-10.00 sec 21.2 MBytes 178 Mbits/sec

[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.00 sec 206 MBytes 173 Mbits/sec sender
[ 5] 0.00-10.00 sec 206 MBytes 173 Mbits/sec receiver

with the bandwidth set to 40 MHz on the router the movie plays without a problem

[ 5] 0.00-1.00 sec 12.4 MBytes 104 Mbits/sec
[ 5] 1.00-2.00 sec 13.0 MBytes 109 Mbits/sec
[ 5] 2.00-3.00 sec 11.9 MBytes 99.7 Mbits/sec
[ 5] 3.00-4.00 sec 12.5 MBytes 105 Mbits/sec
[ 5] 4.00-5.00 sec 12.3 MBytes 104 Mbits/sec
[ 5] 5.00-6.00 sec 12.0 MBytes 101 Mbits/sec
[ 5] 6.00-7.00 sec 11.9 MBytes 99.6 Mbits/sec
[ 5] 7.00-8.00 sec 11.5 MBytes 96.5 Mbits/sec
[ 5] 8.00-9.00 sec 11.1 MBytes 92.9 Mbits/sec
[ 5] 9.00-10.00 sec 12.3 MBytes 104 Mbits/sec

[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.00 sec 121 MBytes 102 Mbits/sec sender
[ 5] 0.00-10.00 sec 121 MBytes 102 Mbits/sec receiver

Is the device completely freezing? If you attach an Ethernet cable does it restore the connectivity?


Yes it freezes completely, does not respond to the remote controller and disappears from the client list on the router.
When I try to connect the cable in this state, nothing happens and it is still frozen and connectivity is not restored.

Okay, I will try and reproduce here.

I’d suggest getting the output of dmesg and posting it for when 80Mhz is enabled and when it’s not as that may yield some clues


Hi Sam,

I tried to run dmesg right before vero freeze and disconnect.


In both your logs, it shows you connected at 40Mhz (check bw_mode) in logs.


I see in the log for 80 correct for bw_mode 80, but I tried uploading again.
I’m also adding a link to a video where you can see and hear how the vero gets stuck at 80 MHz.

40 Mhz
80 MHz

Sorry about that, that was my mistake. I had them both open in notepad and I think I must have accidently clicked the ‘find all in ALL open documents’ instead of the 'find all in the CURRENT document button and didn’t notice that it had switched the active file. For future reference though we prefer if logs are uploaded to

Sam updated the wifi driver in the test build if you would like to try and see if that resolves your issue. I couldn’t reproduce your issue with my Unifi access points so I can’t really say if this will make a difference or not, but I did test the updated driver to make sure it was working so there should be no risk to updating to what is currently in staging.

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Unfortunately, that didn’t help. It behaves exactly the same.
Setting the wifi to 40 MHz is OK for me if it’s just my problem.
I’m just sorry that the Vero 4K+ works fine with the router set to 80 MHz, so I didn’t get much improvement in that regard.

Can you post a log so I can check that you updated correctly?

Otherwise I am not sure - we have sent a good number of units out and not had any issues yet. I can’t reproduce here on 80Mhz but I’m using a Unfi AC Lite. Configuring that seemed challenging…

I just set my RT-AC68U to 80MHz (it’s normally set to 20/40/80) and don’t get any issues playing USB disk → VeroV → router → VeroV → TV.

I can’t get your logs - browser refuses to go there citing security issue.

So it definitely seems to be a problem with just me.

Normally I also have it set to 20/40/80 and my router is also ASUS like yours (RT-AX55). Now I have to have it set to 40 Mhz for Vero to work without any problems. I’ll try to do some more tests with placement etc.

Couldn’t Vero somehow be set up so that I can have 20/40/80 on the router, but Vero only connects at 40 Mhz? Unfortunately I don’t have a single RJ-45 socket in my apartment and all other devices connect via wifi and have no problem utilizing 80 Mhz (ntb, pc, cell phone, TV), so I’m limiting them a bit right now.