Vero1, OSMC 2017.03-1 update, black screen instead of progress bar

You might need to reinstall if you can’t connect to the device at all

Looks like i am having the same issue, performed a fresh install (using October release) things worked then performed the upgrade again. Then a blank screen.

It could be a coincidence, but this is also running on a Sony TV using the Verio v1

Unable to get logs of the unit and tried a fresh install of the latest release and find that the TV screen never shows anything.

Tried a fresh install on another card, and it seemed to work, but the RF-remote stops working almost immediately, and also yatse stops connecting to it. It also looses the websocket connection trying to access the web gui from a browser.

Did a grab-logs -A, but have not enabled logging yet so I guess it wont say much.

I don’t know it the hardware has given up or there are some subtle bugs - i consistently loose the websocket connection when using a browser - that does not happen on the vero 2 or 4k or my rasperry pi 3 all with December 2017 software on the same network.

It’s ok to ssh to it and the supplied IR-remote seem to work.

Which RF remote are you using?
Debug logging is ideal to see what’s going on


The RF remote looks like this:

I enabled debug log and paired the remote and pressed a few buttons:

The pairing seemed to work, but the remote doesn’t.

Here are logs after a reboot and a new RF pairing when the remote worked a few presses, but stopped responding

The IR remote continues to work.

TBH, I see it all the time - and have done so for a long time on my Pi 4 and Vero4K. In my case, the connection is quickly restored. I always put it down to a minor Kodi bug.

I found that too with Chrome. Switched to FF and resolved.
I looked at it once and it seems to poll the web server. I think the web server is single threaded and the AJAX like approach causes problems.

I don’t know why evbug is loaded on your device, but it shows a lot of disconnects.

Jan 10 22:03:18 vero-osmc kernel: evbug: Disconnected device: input52
Jan 10 22:03:18 vero-osmc kernel: evbug: Disconnected device: input53

Seems like the dongle isn’t getting enough power, which would be surprising for the Vero as the power requirements are minimal.

Can you try it in another device like a PC for a couple of minutes? Not all buttons will work out of the box for that iteration of remote, but the directional keys will.


I dusted off my rpi2 running osmc 2017-6 and connected the remote and did a graphical update to 2017-12. It worked flawlessly (good work on the update process!) And the remote worked fine with it.

I’m guessing my vero has some kind of hardware problem then or maybe the ac adapter is wonky. I bought the device upon release, so it’s been running 24/7 since in different parts of the house.

Shucks. Nice theory, but I use FF.

Mhhh … but it could not be such profane thing like a battery issue?
Would be good to split this RF remote issue from the original thread.

Probably not, since the remote works with the rpi 2, also I have tried to change the battery without success on the Vero.

Just for grins wanted to know what power consumption to expect from the RF receiver (took the RF remote and receiver from the Vero 4k which seem to be the same like the one @ogre uses):

So, 20 mA that is really low. I assume you don’t have such USB tester at hand? It only costs some bucks.


Nope, I’m not that into hardware. And since the remote has worked for a number of months before this, I’m more inclined to believe that something in the Vero has broke hardware-wise.

@ogre: Your RF remote works on other devices, my RF remote works fine with the Vero1 -> sounds logical to me that the issue is isolated to your specific Vero1 + related power supply. Other ideas are welcome.

@ogre: Have you tried the other USB port, i.e. swapping them over?


Yes, the first log is from the top port and the second, where it worked a little better is from the lower one.

The issue could be PSU related and it may have worn out over time. However the dongle demands very little from the device; so I’d be surprised if this was the case.


Yes something might be wrong with the remote as well. After leaving it in the rpi over the day it did not work when I got home. So I think that the Vero and the remote will be retired.

I would give another battery a try …