Vero2 CEC error message

Hi, I’ve just replaced my Vero with a Vero2. After going through the standard setup everything looked good apart from I’m getting a ‘couldn’t initialise the cec adaptor’ message on startup. I’ve got the same tv, remote and even hdmi cable connected as I had with the previous vero1 so I don’t think it’s my hardware.
At first my Samsung remote didn’t work at all but I went in to ‘Settings - MyOsmc - remotes’ and selected it from the list and it started to work but I’m still getting the ‘couldn’t initialise’ message on the home screen. Also the new Vero2 is not appearing in my Samsung Anynet list of devices as my original Vero did.
Is there a difference in the way the Vero and Vero2 handle CEC?

Any ideas?

Once when the device boots? Every 5 minutes? How often? Please be as descriptive as possible.

Only on bootup. The message appears in the bottom right hand corner of the home screen for a few seconds and then disappears.


Power down both devices for 10 min
Try another HDMI cable
Post logs when the CEC fails

Hi Sam,

I powered down and swapped the HDMI cable as suggested but got the same result. Same error message. I’ve uploaded my logs and will IM you the URL to view them.

I did notice this in the section at the end of the log:

19:45:52 T:3030409216 NOTICE: Register - new cec device registered on cec->Amlogic: CEC Adapter (0000:0000)
19:45:52 T:3030409216 NOTICE: Running database version Addons20
19:45:52 T:3030409216 NOTICE: Running database version ViewModes6
19:45:52 T:3030409216 NOTICE: Running database version Textures13
19:45:52 T:3030409216 NOTICE: Running database version MyMusic56
19:45:52 T:3030409216 NOTICE: Running database version MyVideos99
19:45:52 T:3030409216 NOTICE: Running database version TV29
19:45:52 T:3030409216 NOTICE: Running database version Epg11
19:45:52 T:3030409216 NOTICE: start dvd mediatype detection
19:45:52 T:2949411824 ERROR: CecLogMessage - AllocateLogicalAddresses - failed to allocate device ‘0’, type ‘playback device’
19:45:52 T:2949411824 ERROR: CecLogMessage - failed to find a free logical address for the client
19:45:52 T:2949411824 ERROR: CecLogMessage - failed to register the new CEC client - cannot allocate the requested device types
19:45:52 T:2949411824 ERROR: CecLogMessage - failed to register a CEC client
19:45:52 T:2941023216 ERROR: OpenConnection - could not opening a connection to the CEC adapter
13:25:19 T:3030409216 WARNING: JSONRPC: Could not parse type “Setting.Details.SettingList”
13:25:19 T:3030409216 NOTICE: ActiveAE DSP - starting
13:25:19 T:3030409216 NOTICE: initialize done


Try configuring the device as a Recorder in Peripherals -> Input -> CEC


Sorry Sam, I don’t understand what you’re asking me to do.

I can’t find Peripherals-input-CEC.

I’ve looked in System-settings-input devices-CEC but can’t see an option to set anything as a Recorder?

Change device_type from 1 to 4 in /usr/share/kodi/system/peripherals.xml and see if it helps

Hi Sam

checked the peripherals.xml as mentioned and the device_type was already set to 4. So I tried changing it to a 1 in case your instruction was a typo. This worked :slight_smile: initially :frowning:

I changed device type to a 1 and did a soft reboot, there was no ‘initializing cec’ error on the home screen and kodi immediately appeared on the TV Anynet+ list :slight_smile: fantastic.

Next step, I went to ‘MyOSMC - remotes’ and selected the normal samsung remote that I have. I rebooted the Vero again and was back to square 1. The error message reappeared and kodi disappeared from the Anynet list :frowning:

Since then I’ve tried reverting back to the original kodi remote, powering off both devices for 10 minutes, setting the device type back to 4 and then back to 1 again but I’ve been unable to recreate that fleeting moment of success.

Current position is default kodi remote, device_type=4 and CEC is not initializing.

The settings in MyOSMC - Remotes is only for remotes that communicate with OSMC via IR or RF. This should not have any effect for your CEC communication.

Did you stopped Kodi before you edited the file?

Thanks fzinken, I didn’t realize that about the remotes. I’ll leave it set as the default kodi remote and won’t touch it again.

I didn’t stop kodi before editing the file but I did check following the reboot that the file had picked up the change. I’ll try again with kodi stopped. What’s the cmd for stopping and starting kodi? and can you confirm if device type should be 1 or 4 to be a ‘Recorder’



I used the “sudo systemctl stop mediacenter” and “sudo systemctl start mediacenter” commands to stop and start kodi (hope that’s correct) and edited the peripherals.xml file again. I tried with device_type set to 1 and device_type set to 4 but got the same error on both occasions.

ERROR: CecLogMessage - AllocateLogicalAddresses - failed to allocate device ‘0’, type ‘playback device’

I noticed that regardless of what I set device_type to in the peripherals file the error always says "type ‘playback device’ which seems strange.

I did a bit more digging and found a cec file “cec_0000_0000.xml” in this location /home/osmc/.kodi/userdata/peripheral_data

this also has the device_type parameter in it and it appears to remain set to 4 regardless of what happens in the peripherals.xml file.

Not sure if this information helps at all.

Any more suggestions?

OK :slight_smile: Good news
Updating “cec_0000_0000.xml” in this location /home/osmc/.kodi/userdata/peripheral_data seems to have fixed the issue. My Samsung remote is working correctly and Kodi is appearing in my Anynet+ list.
:slight_smile: I’ve soft rebooted a couple of times but not risked powering down. I’ll let you know if the issue reappears after that.

So was this file meant to get updated when I edited the peripherals.xml ? Did I do something wrong or is this an issue?

FYI. device_type is now set to 1 in both files.

This may mean you have another CEC device attached which was preventing Kodi from taking that logical address. The default settings work for most users, and we set the device as a Player by default to ensure that all buttons work as expected.