Vero2 - Wired LAN problem


#1

Hello,

I do not think I can find a solution here, because I think the problem is material (and has probably always existed, my son who gave me his Vero2 (after mine, which worked perfectly, died after a storm-lightning) told me that wired, it worked badly but he put it on the account of a CPL connection) - the Vero2 is out of warranty, I ask nothing, just know if I’m wrong if a solution exists (?), without much believe it … I have already ordered a Vero4K replacement.

My problem :

  • The Vero2 normally access the Wi-Fi network, obviously limited by the speed of Wifi, at home 8mbs (I can not read the videos that are more than 5 GB), this is normal.
  • By cons in wire, even the exploration of files is slow! strictly impossible to read, even a small video, without saccade! I think the maximum bitrate is 1 mbs with connection times of several seconds (hourglass, buffer), while wifi is instantaneous.

I tested everything: cable, box (router), connection with the PC, etc. everything is normal ! it’s not Samba (since Wifi works), and I have a normal speed when I plug a PC instead of the Vero2! (several tens of mbs)

I think it’s a hardware flaw, there is no way to see anything in the log, since apart from slowness, everything works, I have my internet connection, etc.

If you see a software solution ???
Or if you confirm that it is material, so irreparable on this kind of product …

What do you think ?

thank you


#2

Logs can tell us allot.

Are you using fstab or Kodi based mounts. Kodi mounts can be problematic.

Have you tried using iperf3 to test the network?


#3

So WiFi and Wired do work, but very slowly?

Did you try a reinstall from osmc.tv/download first?

Sam


#4

No, only Wired is very slowly, Wifi is OK, even faster than Wired (?!); folder navigation is instantaneous with Wifi, everything is normal in Wifi.
but it’s only wifi … I need a wired connection to read the big files !
With Wired, the hourglass turns turns turns when we change the folder (5 to 30 sec) and video jerky or freeze during 5 - 30 sec… as if the flow was 1mbs… ???

I’ve delete .kodi “to start anew” =>The same problem with Wired Connexion !
but I do not know if we can make a reset of OSMC (there is no button for the reset on the Vero2)

PS : bmillham : There is no mistake, everything works! except that the wired is slow - No fstab, nothing, just Samba for windows network, as I did with my old Vero and my old raspberry pi: I’ve always been able to read big files in wired!
I already had 3 raspberry, I installed 2 (at brother and sister), I had a Vero2 : I have never seen that ???!!!

PS2 ! iperf3 ? I’m sure of my installation, with PCs, Cam, etc. wired normally operates with proper flow ! (I can copy at least 60mbs)


#5

What do you mean by this?
E.g. when using wired on the Vero what is the iperf throughput to your PC?
Also you might want to install ethtool to check what is the negotiated speed.


#7

Hello SAM

OSMC is up to date on the latest version,
I do not understand: Will there be a way to make a “reset” from a disk image?
I thought it was not possible because we have no SD card but the memory is integrated in the Vero2
There is a way ?

That said I think it is rather a physical failure, perhaps a bad connection in the LAN between the RJ45 socket and the controller?
I just came here to find out if it could come from a software problem, without really believing it …

fzinken: Everything I plug into the RJ45 cable works normally with a bit rate corresponding to the 100 Mbps connection of my router.
The Vero2 is the ONLY malfunction in wired (the Wifi is OK)


#8

Vero2 has internal memory but you still can do a reinstall using an image that you provide on an SD Card (Vero2 has a SD Card Reader).
https://osmc.tv/wiki/vero-late-2015/reinstalling-osmc/

That doesn’t answer my question what is your iperf result if you try between the Vero (wired) and your PC?
Also as suggested check ethtool


#9

Maybe it is a bad cable?
Did this happen after an update?


#12

finken: OK, I did not see that it was possible, I will try to reinstall osmc, thank you
— I will test with your software, but I do not see the utility, whether from the PC or the NAS (so in SAMBA or NFS!), it drains drop by wire! it’s slow !!! the problem is EVIDENT !!! what is the point of having the exact figure of the speed of the turtle compared to that of the hare when you see them both moving in front of you? … so …
And I repeat that Wifi, everything is fine!

Sam: I already said above that I tested my cable, I even plugged into the router with 2 other cables that I had in addition and were still packaged! (new) and that if I plug on the RJ45 plug something other than the Vero2 it works normally, the flow is normal, as fast as it can be in wired

It’s crazy how you do not want it to be the Vero2! you think I tried all the tests for days before coming here! I tested all the elements of the chain!
My only request was to know if it could be software, as I was told here, I will try to reinstall OSMC, I will come back here after the weekend when it will be done to say if the problem persists (hardware failure) or not (software problem) …

I’ll be back when I finish these tests, thank you for your indications


#13

Take a deep breath and enjoy the evidence


#14

@thry.martin1 I made some changes to Ethernet in the last update. Maybe this is causing the problem.

I suggest you try an older version like 2018.02. See if it works properly before updating OSMC


#15

Sam > new version causing the problem ?
No, I do not think so, Sam, when I got this Vero2, the last update was in July 2017 and the problem was already present. My son told me he had stopped because of jerks and freeze he attributed to a CPL.
With the Wifi, which works very well, I see almost all my videos, I have a problem only on files over 10GB that the Wifi can not, anyway, manage. (which is normal)
With a measurement utility, on all videos that “pass” the Wifi provides exactly the desired flow. The cable can not arrive at half this rate, hence freeze, jerks … I can not strictly watch anything (in wired) !
Worse, waiting to open a large folder is such that it becomes unusable in wired (several minutes, against 2 seconds in Wifi and immediatly in wired before this Vero2)
Anyway, I already ordered a Vero4K, which I was considering the purchase for a while (if you remember, for testing and reading the 3D interface) my problem will be solved in stride since remember that the network works normally when I plug something other than this Vero2! (Including raspbery pi and another Vero2 that I installed in my second home).
I will try to reinstall OSMC and if it still does not work, it does not matter, it can still be useful as a spare video player…


#16

It was a problem with this Vero 2 and not a network problem

The Vero 4K received today: it works perfectly:

  • for the connection Wire!
  • for the 3D interface! (yeah !)

with more compared to a raspberry pi, the h265 and the 4k

Thanks Sam!

PS: I will try to reinitialize osmc on the old Vero 2 who had a malfunction on the wired connection, sorry, still not done … but I would, promised, that we know once and for all if this was hardware or software.


#17

As promised, I finally decided to reinstall OSMC on this Vero2
The problem is the same (Wifi OK, Wired No: slow, jerks and freeze)

it’s Hardware (can it just be bad contacts / soldering from the socket to the controller?) …
Well, we can close this discussion, since there is no software solution, a material malfunction it can happen … and here if we are content with videos of less than 8GB, WiFi it works normally, so the device is still functional for this use. So, either I keep it for rescue, or I sell it by warning the buyer, I’ll see …

On my side I am completely satisfied with the Vero 4K
FIne!