Vero4K audio mixer and amcodec issues

Hi Sam,

This post is a long time in coming, but you know… life. I received my Vero 4K many months ago but only got around to setting it fully up a month ago. At a high level, its a great device, however, there’s been a couple issues I’ve been struggling with and have only recently had the time to dig deep into them.

First my environment:

3.1 dual sub Polk Audip speaker system
Onkyo receiver set for direct (no DSP processing)
Vizio low end 60" LCD monitor

Before the Vero 4K I had been using an old Intel NUC running Kodibuntu. For comparison, I flashed it today with LibreElec today so both the Vero and NUC are running Kodi 17.4.

Now the issues.

First, there seems to be a serious problem with the Vero 4K audio mixer. Both V4K and NUC are configured for 3.1 channels with stereo upmix and passthrough enabled. With the same 2-channel source, the NUC correctly up-mixes to 3.1 channels with actual content being provided on both center and sub outputs. With the same source, the V4K is sending a 7.1 PCM signal with no output at all on either center or sub channels. It seems stereo upmix is enabling all possible channels while not doing any actual remixing at all.

The second problem is with the amcodec video hardware decoding. It seems about 1 in 5 h264 video sources drop 99% of the frames. ie. I get solid audio playback, but video only provides the occasional still image update. These same sources play flawlessly when amcoded accelleration is disabled. These sources also play flawlessly on the NUC with VAAPI acceleration, as well as my linux laptop. I’ve read through some other the threads regarding this with John Oliver seemingly being problematic. I’d extend that to almost anything from HBO, but the fact is its only the amcodec that seems to have a problem with these sources, so I’m reluctant to agree that its a problem with the original transcoded video, and I’ve yet to see a PROPER posted for any of the episodes I’ve had problems with in the last month.

I can live with amcodec being disabled, as software decoding still manages my highest quality movies. As long as running the CPUs at 95% isn’t going to cause thermal issues down the line. :slight_smile: Unfortunately, the audio mixer is a deal breaker if it can’t be resolved. As is, the V4K audio sounds thin and lifeless compared to the NUC. The reason I use Kodi to upmix is so I don’t have to keep switching the receiver’s DSP modes.

My free time for projects is limited, but I’ll do what I can to help resolve these issues.

ps. before I forget, how can I turn off a lirc remote config? I was playing around with the remote setups when I first got the V4K, and now my NUC remote is controlling both lol

Hi,

You can change this in My OSMC -> Remotes.

I’m looking in to the audio situation and seeing what can be done here.
I’ll revisit John Oliver but it’s a bit lower down on the list.

Sam

Wow, that’s a quick response. I was more wondering if there was a way to disable lirc entirely, but setting it to the OSMC remote did disable the MCE, so all good.

Understand. In trying to resolve the HBO amcodec issue I did come across a couple threads on the KODI forums that this had been disabled at of Kodi 17.1… but those were android specific so I don’t know if that applies here.

My top priority at this point is the audio mixer.

It’s doable (masking the service or disabling) but unnecessary hassle.

We still use libamcodec for hardware acceleration.
Android moved to the standard MediaCodec approach because Team Kodi were frustrated with vendor specific hacks.

Sam

Sam,

The Sept release has functionally resolved the audio mixer issue. While it is still reporting a 7.1 channel PCM stream on my receiver despite being configured for 3.1 channels, I’m now getting the expected audio content on both center and sub channels.

The amcodec issue still persists. I don’t know if this helps or is even relevant to the video decoder, but I’ve noticed the following pattern. Videos with 59.940 FPS playback and 2-channel 32bit AAC audio always seem to fail, while videos at 29.970 FPS with 2-channel AAC audio are fine. Either video frame rate plays fine with an AC3 passthrough audio stream.

Hi @moshbox

Thanks for your report. Some users reported problems with the last audio changes, so I have reverted things. In the interim, if you’re happy with audio as it is I wouldn’t recommend updating when prompted to do so.

I’ll follow up on the amcodec issue shortly.

Sam

@sam_nazarko,

So it appears this only resolved the stereo upmix for 2-channel sources, but being 90% deaf in one ear the odd mixing with 5.1 sources was probably too subtle for me to detect. I was playing with @swrobel’s test files this morning and noticed things are all over the place with both the Sept 1 AML-M8AUDIO.conf and the Sept 2 rollback.

Notably I’m not getting a FL at all, SL & SR are going to the front speakers, and C is either correct, or output on FL depending on the test file. I’ll post more detail shortly on the other thread to keep everything together.

Most people reported that the new AML-M8AUDIO.conf works as expected; but there were a couple of reports of problems so we rolled it back.

Sam