Vero4K bricked? Is it recoverable?


While watching a video on my Vero4K, it suddenly powered off. I tried unplugging it and plugging it in again and the red LED just blinks quickly every 7 seconds or so. I burnt the image Vero4K 2022.09-1 image on a USB stick (using [1]) and I tried powering on the Vero4K with the USB stick plugged in, but nothing happens, it keeps blinking the red LED and the USB stick is not accessed.

Is there another recovery method I could try? Do I need to open it up? What could have caused this?


[1] sudo dd of=/dev/sdb if=/tmp/OSMC_TGT_vero3_20220918.img bs=1M conv=fdatasync

If the LED is blinking then either the power supply is not stable or the device is resetting itself very early during the boot process.

I’d try another power supply first.

It could be just the power supply failing.
Do you have another power supply with the same specs? Or do you have a USB A-A cable then you can power the Vero via the USB port.

1 Like

OMG, you’re right, the power supply had come a bit loose! Thanks, @sam_nazarko, amazing support!