Vero4k+ can't access USB drive through Synology NAS DS116


I’m having a problem with my new USB drive(HDD) that I’ve connected to a USB 3.0 slot on my Synology NAS DS116. The NAS is connected to my LAN and I can access the USB through my computer in the network but not through the Vero4k+? The Vero finds and has access to the internal NAS HDD.

I can actually find the directory of the external drive in Kodi but I can’t get in to the directory? Any suggestions on a solution for this problem?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Are you attempting to add this location as a source or are you accessing through Kodi file manager? If attempting to add as source, only directories will be shown, not files, because only directories are intended to be set as a source.

I’m trying to add the location as a source for video files, as I have with the internal HDD.

So do you see the folder you intend to add? It’s expected that you will not see the individual files in this context.

Yes I see the 2 folders when I NFS search for the NAS IP, but I can only open the folder directory for the internal HDD, not the external one.

You’ll probably need to provide logs then. And make sure permissions on the NAS shares are both the same.

Here is how I setup this on my Syno DS214plus for nfs:


At a first glance you allowed access to the nfs folder for ip on the Synology but the vero has got ?
On the vero you’re using as address for the Synology.

Your Kodi sources.xml shows that you have two references to the volumeUSB1 drive

        <path pathversion="1">nfs://</path>


        <path pathversion="1">/mnt/volumeUSB1/</path>

While the first entry, which uses Kodi-based NFS, seems like it might work, the second, which uses an fstab entry, is incorrectly specified: /mnt/volumeUSB1/usbshare1-2 nfs noauto,x-systemd.automount 0 0

Assuming that you have already created the mount point /mnt/usbshare1-2 (or a name of your choice), you might have a better chance if that line is something like: /mnt/usbshare1-2 nfs noauto,x-systemd.automount 0 0

Yeah I just tried the fstab due to that the Kodi-based NFS didn’t work.

Do you mean that the client IP under NFS access should be the IP of the Vero, x.200?

Yes, see also DSM help

That worked well, thanks!