Vero4k - Connect to FreeNAS

#1

Hi Folks,

I switched back from my Windows Media PC to the Vero because I built myself a FreeNAS System.

I had to set up Shares via CIFS/SMB because I manage my files on my Windows Computer.
But now I have the problem on the Vero side - As many people say on this forum, NFS is far superior than CIFS/SMB.

So, what do I do now?

I tried to connect my Vero to the smb share using the /etc/fstab guide for smb but everytime I try to connect to the share I get an error with “No such directory”

Log can be found here: https://paste.osmc.tv/ilapegesit

Has anonye a suggestion for me, how I can manage my files on my Windows 10 Machine via NFS?
Or maybe a solution to my “No such directory” problem?

Cheers
quintz

#2

Just enable NFS and SMB on your freenas, then you can connect from windows with smb and osmc with NFS.

Generally the advice is to use autofs instead of fstab approach as it is easier to trouble shoot

#3

https://www.ixsystems.com/documentation/freenas/11.2-U5/sharing.html

In FreeNAS I have to choose between sharing a directory via NFS OR SMB, both is apperntly not possible because of the risk of data corruption (as I found out in a google search marathon)…

Maybe the SMB service is not running on my Vero…Have to check that this evening!

#4

Wow super odd.

No need for SMB service on the Vero as you just will use the client.

Ok if we now stick with SMB let’s start the trouble shooting.

  1. Install smbclient via sudo apt-get install smbclient
  2. Show the output of smbclient -U osmc -L 192.168.0.1
  3. Show output of ls -lah /mnt
#5

I have mounted several datasets with NFS and SMB using FreeNAS at the same time without any problems. I have mounted those datasets read-only with NFS for Vero4K and writeable with SMB for PC. I did not have any data corruption so far.

Edit: I think it might be a problem in a multi-user environment with many users not knowing each other. If you are the only one using those mounted shares you actually know what you are doing and there should be no problems in mounting a dataset with NFS and SMB at the same time IMHO.

1 Like
#6

Thanks for the responses.

I now managed to connect Vero to my FreeNAS via SMB.
I just had to add the shares manually , otherwise I had a „File Exists“ error.
But when adding manually, I could enter user and password and now it works flawlessly.

Even 4K Videos are playing without a hiccup :slight_smile:

#7

I have never had issues with SMB, admittedly with a QNAP NAS, the issue I find with Kodi is the SMB browser is no good, I prefer to add a network location using SMB, this appears as a permanent share location, I then add video locations using the newly created network location.

I have no issue with 4k or any other video over 1Gb SMB share. my NAS runs ext4 filesystem.

Neil

#8

This is only if you have read/write on both and even then only in certain circumstances. This is because the file locking mechanism (the ability to lock a file so others cannot modify it at the same time) is not compatible between NFS and SMB servers so theoretically a client on each SMB and NFS can lock the same file at the same time and each think they are the only client that has a lock to that file. This is an important operation in databases and the like. If one of them, SMB or NFS, is read-only, you will not have issues. Additionally you won’t if you don’t use something that relies on file locking like databases do.

#9

Thanks for the clarification!

I’ll watch the performance of the SMB Share - if this isn’t working for some reason soon I’ll switch to NFS