Vero4K constant rebooting loop

I’ve had my Vero4K since 2018 and it has been working fine up until now. When I came home from work yesterday, I found my Vero4K in a constant reboot loop.

It started booting (went from red light to blue), got to the Kodi home menu for second or two, then shut down and started rebooting again. It seemed to have been doing this for a couple of hours.

I have tried to restart it after unplugging everything (HDMI, network, USB) and changing power supply, but it still reboots over and over again. When I then tried the original power plug again, the light stayed red and it didn’t boot anymore. Then I tried another power plug again and it booted, until the Kodie home screen was displayed, then it shut down and started booting again, over and over.

Is there something I can do to fix this? Reinstall? Or should I be glad for the memories and start to look for a replacement? :slight_smile:

First try Reinstall

If that doesn’t work could try powering via USB A-A