Vero4k+ crash after update

Hi, noticed today there was an update, so went ahead with it.
I let it run, switched the TV off, and came back hours later to see a blue sad face when I switched the TV back on. Now it goes from sad face to black screen regardless. Saw some command lines but didn’t get them down. I tried unplugging and rebooting.

Now, just before doing an update, I did a backup through the main menu. A few questions on how to fix things :

  • where is that backup stored ? If I do a full reinstall with sdcard and reset button, will I lose that backup ?
  • does that backup only contain the raw settings ? (I.e. if I reinstall everything am I going to reinstall issues by restoring that backup ?
  • I used that grablog -A command line, have a link, not sure if I can share that link publicly or if it contains personal information. File looks pretty consequent. I tried rm log as found on that other post, rebooting, new paste still seems huge. Who knows.

Where to go forwards ? If I can avoid losing settings, good ; but I do want a reliable outcome, so may be worth it if I have to.
Before this major crash, forgot to mention ,I did have rare occurrences of sad faces but they always sorted themselves out with an automatic reboot, so quite tolerable.

Many thanks for your advice getting this 4k+ back up and running.

I’d suggest uploading some logs so we can see what went wrong.

The backup tool prompts where you’d like to save the backup, so its location will be dependent on what you selected


Thanks for the quick response.

(removed - thanks again)

I don’t recall setting up a location ; how can I check ?

Thank you for your help.

This might help:

Thanks ; doesn’t seem to help though. I had disabled the test repository quite a while back. Would rather stick with a stable version.
Or maybe I am not focusing on the right part of this post ?
Thanks for throwing ideas though.

I’m not sure what you did. You need to enable it and change videoimprovevero to videoimprovevero49. Then run update/dist-upgrade again.

You’re running on the (still testing) 4.9 kernel.

Ah well that’s a surprise ! Thought I was on a stable version, hence why I commented out that source list…
I presume I have to wait for a stable 4.9 version before quitting the test versions, or reverting to older stable version, which may be a lot of hassle .

Thanks - will test that source change and report back.

Yes, I believe the only way back to the 3.14 kernel is by a reinstall.

That’s correct.

Well thank you all. That has fixed it. Uncommented sources line, added the “49” , ran update and things are back up and running now.
Once 4.9 stable is out, I’ll comment the line back : clearly not knowledgeable enough to be running on test versions. I’ll have to look out for it.

I’ll also have to look into where my backups are being made, so I don’t feel silly if I break things again.

Thank you both.