VERO4K - Get Context Menu working with new Samsung SUHD TVs (KS8000)

Thanks @bmillham and also @Soli

I turn-off the CEC via TV and installed the IR extender and seems to be current available remote options via OSMC Settings --> Remotes not compatible with my Samsung TV remote as when selected no keys working in the remote.

I dug-up old Samsung TV remote which showing in the picture of OSMC and that one works with OSMC but not with the TV so I am back to my issue of having 2 remotes.

Any way I can add my TV remote to OSMC remote list? Or how I can overcome this new problem?

You must go into TV configuration of your Samsung TV and manually “add” devices (the same way you did it with your other box) for it to program the IR codes of that remote. There’s probably a built in remote profile in OSMC that’s also supported by your Samsung TV/BN59 remote.

Thanks @Soli… Unfortunately VERO is not listed in the SamsungTV universal remote setup list. I did try to 10+ different manufactures but no luck.

Note that my foxtel box came up once I searched…

You don’t add a Vero.

OSMC has different profiles to let the IR sensor work with different IR remotes. So go find the one named XBOX ONE, add a XBOX ONE as a media device on your TV and your Samsung Remote will send out XBOX ONE remote codes and hopefully everything works.

Or use another profile if XBOX ONE doesn’t work or exist. If none work, then you must make your own profile and/or custom keymap file. This is a bit advanced and you should make a new thread if you need help with that.

Or just order a FLIRC2 which translates IR codes to regular keyboard presses.

1 Like

Oh @Soli you are a life saver… yes you are correct and your method worked…

  1. Set the VERO4K - OSMC Remote setup to XBOX-One
  2. Select the TV Universal Remote and selected Cable box --> Manufacturer As XBOX --> XBOX One as the device to control
  3. Select Power test and all working…

Now the next challenge is how to configure the “Return” long-press to “Context Menu” as currently it’s pointing to Shutdown() and when I use the key map app to edit the key VERO4K is shutting down

Anyway I can remove below mapping?
13:28:15.842 T:4110066608 DEBUG: OnKey: rewind (0xc4) pressed, action is ShutDown()

My Current KEY MAP File as below

osmc@MbrVERO4K:~/.kodi/userdata/keymaps$ cat gen.xml
<keymap><global><keyboard><key id="251">activatewindow(home)</key><key id="201">contextmenu</key></keyboard></global></keymap>osmc@MbrVERO4K:~/.kodi/userdata/keymaps$

Above was also resolved thanks to below thread…

Adding below to remote.xml fix the shutdown and then used the App to map the key to ContextMenu…

remote.xml (in ~/.kodi/userdata/keymaps)


After the Key-Map editor App:

<key id="196">contextmenu</key>

Big thanks to all (@sam_nazarko / @Soli / @bmillham / @DBMandrake) as I finally got my VERO4K / TV / My Foxtel Box all working with me Samsung smart remote app…

Hope this thread will help others as well…

1 Like

Good to hear. Provided you don’t get an Xbox One, in the future you won’t need to change this now.


1 Like

@sam_nazarko @DBMandrake

Kindly pointing out that after the latest VERO4K May release above IR mapping feature broken and it’s not working anymore. I got 2x VERO4K devices on this setup and both stop working after the May upgrade.

I have manually restarted the VERO4K and TV both and also redid the above steps again to make sure it’s related to setting retention issue but no luck getting it to work.

Any steps how I can rollback to previous version until this issue fixed? Also let me know know what you need from me to identify and fix this issue as others who using the same setup will report this soon…

For now I am back to CEC without the context menu…

Is there an update on this? I have the same remote and can’t make it work with CEC. I managed to get it work with the Xbox profile, but it doesn’t work perfectly and there’s a delay (sometimes need to press twice)

@sam_nazarko, I have debug on with verbose for libCEC, but can’t see anything in the log when pressing the buttons, does it mean CEC isn’t working? It’s installed in the Peripherals (v4.0.2 - fw v5).

I believe the issue was resolved several months ago. I remember checking with @sniferx1 about some of the IR issues that cropped up back then.

If CEC doesn’t work at all, then this is a different issue. The issue only concerned IR remotes. Try powering down both devices at the mains for 10 minutes; and try another HDMI cable.


I see, yes, the problem was just related to CEC.

I unplugged the HDMI cable and plugged again and now CEC is working without problems. If anyone finds the same problem, try doing this and NOT configuring the Universal Remote function that pops up when you plug a new HDMI device.


Just got my vero 4k and am very happy with the box :wink:

Just install this with some addons and working fine.

only my tv remote is not working.

TV: Samsung Q7F with Anynet+
Remote: Samsung one remote
HDMI1: empty
HDMI2 (ARC): Bose soundtouch 300 - CEC is working but problems when the TV turning off
HDMI3: Vero 4K - CEC is not working at all
HDMI4: Xbox ONE - CEC is working as shut be

So now looking for a solution

I tried the option from dggomes and the CEC was working until I started a movie.

Greeting DennisK

Have you tried to unplug TV and Vero from power for a few minutes?
Also another HDMI cable maybe worth a try

Yes, I tried that and didn’t works.

Today I gone call Samsung support.
This is really A problem with the TV.
When I had known that the Tizen was so limited, I didn’t buy A Samsung.

Thanks fzinken, badly for me it’s not the solution.

Greetings Dennisk

Try disconnecting other peripherals temporarily (Bose, Xbox) and seeing if CEC works. If it does, then we should have a workaround for you.

Hi thanks for the option.

Had A lot of talking with Samsung.
now we have A new software version for the TV we now have 1210 installed on the Q7f.

From there we have more problems with the Bose en Vero. This week A technician from Samsung is coming by to replace the TV Blackbox. Three is no role back from the update and we are going to look for a new TV and it’s not going to be a Samsung.

The help from Samsung is very bad. And Tizen is not so great at all.

So dit you have any suggestion for a good 4k TV?

And Samsung is not aware of any problem with kodi boxes at all. :rage:

2 days ago we bought a new TV.
Its A Sony kd-49xe9005 take a look at the review

The Bose soundtouch 300 and Vero 4k now working perfectly with the TV remote only disabled the CEC on the Vero 4k and tare is still A glitch on CEC, he switches the TV on again after a few minutes.
And now the vero can not be turned off when the TV is turned off.

but overall I’m very happy.

greetings Dennis

Disable the set active source option