Vero4k GUI sounds and Standby passthrough sound not working

Hey guys,

first of all, I love the new Vero4k. Everything runs much more smoothly than on my Vero2.
I have to say though this one gave me a bit more trouble than I am used to with osmc which usually was just install, copy config files and go.

So, an overview of my Setup:

Vero is connected to a Pioneer VSX-924 AVR
The AVR has a samsumg ue-46f6170 connected via HDMI and supports a 5.1 speaker system

Media is streamed to the Vero from a QNAP NAS via nfs and the QNAP box also hosts the mysql database for the library.
With the new Vero4k I just switched out the Vero part (using also the new power supply and hdmi cable).

So, at first I had troubles with the hdmi cable which I was able to sort out but I wanted to leave the info here in case someone else runs into the same issues and ends up here:

When I first set up the new vero the HDMI signal kept on being interrupted (screen went black and the little HDMI led on the AVR turned off at the same time). After lots and lots of testing different settings and HDMI Ports on the AVR it turned out that the hdmi cable that came with the vero4k just doesn’t work with my AVR. The same cable worked perfectly when I used it to connect the vero directly to my TV. It also works when I use this cable to connect the avr to my TV and another one to connect the vero to the AVR.

Now to the problems I wasn’t able to fix. The GUI sounds just don’t work when using the AVR. They do work when I connect the vero directly to the TV. They did work with the vero 2 in the same setup. Also all media sound plays as expected.

Also I noticed that when using the hdmi passthrough feature of my AVR only video works and no sound at all. I never tested that with the old one though, so it might be something with my AVR.

Both issues aren’t big ones for me but it sure would be nice if I could get them to work.

These are my audio system settings. LEt me know if you need any more data, logs etc.

Audio Outbut Device | AML-M8AUDIO, PCM (I tried changing this to the hdmi one without any effect)
Number of Channels | 2.0
Output configuration | Optimized
Volume control steps | 90
Maintain original volume on downmix | true
Stereo upmix | false
Boost centre channel when downmixing | 0dB
Resample quality | medium
Threshold for pitch correction | 2
Keep audio device alive | 1 Minute
Send low volume noise | true

Play GUI sounds | Only when playback is stopped
GUI sounds | Kodi UI sounds

Allow passthrough | true
Passthrough outpu device | AML-M8AUDIO, HDMI (greyed out)
Dolby Digital (AC3) capable receiver | true

  • Enable Dolby Digital (AC3) transcoding | true
    Dolby Digital Plus (E-AC3) capable receiver | true
    DTS capable receiver | true
    TrueHD capable receiver | true
    DTS-HD capable receiver | true

Enable audio DSP processing | false

Also here it a log dump

If you want to use passthrough, change as follows:

Disable AC3 transcoding

Some people seem to be having some issues with the supplied cable. It’s an HDMI 2.0 one. We might just ship an HDMI 1.4 one in the future.



thanks for the reply.

Unfortunately that didn’t help. I also tested the passthrough feature with my chromecast and it is working.
I also removed the Vero hdmi cable from my setup completely making sure it’s not the issue. No change so far.

Also there is still the issue with the GUI sounds not working at all when using the AVR. Even without passthrough.


I’ll need to see debug logs to know what’s going on here. Does your AV show any PCM sound being transmitted?