Vero4K - issues with some video files

I have a playback issue with a Vero4K, with some specific files. I’ll try to follow the “questions” as per the guidelines

**The issue you are currently experiencing with OSMC**

we use the Vero4K to watch video produced by several people. Some use Adobe or Resolve to create the movie, and there are never problems with these files. Some other video tools result in issues: a movie produced in Pinnacle Studio results in a video halt about 7 second into the movie. All other video players (windows, Mediator, …) play that same file perfectly. The log is from this example.
Similarly, video files create by Casablanca software, often have issues too. There playback does not halt, but creates “blockiness” in the video regularly during the playback.

**What you were doing when this issue occurred**

play the movie

**Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.**

file can be provided if needed. I made an extract of the first 17 seconds, where the halt appears around second 7.

**The device you are currently running OSMC on**

Vero4K, running May23 update

**What peripherals are attached to the device?**

usb-stick, remote controle dongle, screen via hdmi

**Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?**

not introduced by new version… blockiness (casablanca files) have been there all along.

Log: Log file

Mediainfo of this videofile:
Complete name : JV2022-2023 (intro 17 sec).mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/mp41)
File size : 17.6 MiB
Duration : 17 s 664 ms
Overall bit rate mode : Variable
Overall bit rate : 8 337 kb/s
Frame rate : 50.000 FPS
Encoded date : 2023-10-04 19:57:53 UTC
Tagged date : 2023-10-04 19:57:53 UTC
Writing application : Lavf60.3.100

ID : 1
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : mp4v-20
Duration : 17 s 660 ms
Bit rate mode : Variable
Bit rate : 8 219 kb/s
Nominal bit rate : 12.0 Mb/s
Maximum bit rate : 11.2 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 50.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.079
Stream size : 17.3 MiB (99%)
Language : English
Encoded date : 2023-10-04 19:57:53 UTC
Tagged date : 2023-10-04 19:57:53 UTC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 17 s 664 ms
Bit rate mode : Constant
Bit rate : 112 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 242 KiB (1%)
Language : English
Default : Yes
Alternate group : 1
Encoded date : 2023-10-04 19:57:53 UTC
Tagged date : 2023-10-04 19:57:53 UTC

I just updated the Vero4K+ to the December release, and tried the same file… remains exactly the same: image freezes around second 7, audio continues to play.

This codec is quite “special” and was mainly used in the early 2000 for internet streams and later in Video Conference systems so not the typical ones for a media center.
Anyway your issue might be same as this thread, not sure if @sam_nazarko found a solution.

Thanks for the quick reply… I tried to re-encode that sample with Handbrake, and that output file seems to play fine. The MediaInfo on the re-encoded file is:
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L4
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 4 frames
Codec ID : avc1

Whilst you may think this solves the issue (technically, it does), I’m still in trouble… the members of our videoclub bring their movies to the club gatherings, and there I do not have the possibility to re-encode on the fly.

I also tried one of the files, generated by the Casablanca software (version on a Windows PC), and here is the MediaInfo from a file which has this “blockiness” issue (artifacts) throughout the movie:
Format : MPEG-4 Visual
Format profile : Simple@L1
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : mp4v-20

Seems it’s using the same “Matrix: default (H.263)” format setting. So both issues are driven by the same problem I would think.

I read the other thread fzinken is referring to, and seems indeed the same problem with H.263. Also read that Sam thought it would be relatively easy to solve… but that is more than a year ago. Hope something can be done.

Now that you highlight these codec issues, I remember that in the past, we have had similar “blockiness” issues playing a DVD rip (iso file), and small jumps in the playback (like dropping a frame very regularly). That video was INTERLACED.
Out of curiosity, I checked the MediaInfo of such a file:
Format : MPEG Video
Format version : Version 2
Format profile : Main@Main
Format settings : CustomMatrix / BVOP
Format settings, BVOP : Yes
Format settings, Matrix : Custom
Format settings, GOP : M=3, N=12
Format settings, picture structure : Frame

We are in 2023, mainstream codecs should be H.264, H.265 and VP9, AV1

But I understand you can not control the Codecs other people bring. But to be honest I don’t have a single video encoded in H.263 so maybe you give some training to the people about video codecs and their usage.
If you read the below articles none of them mention H.263.

I know… I’m working in 4K, on a H265 codec since a few years now, H264 prior to that.

You have to understand that the person in our club who works with that old Casablanca editing software is 83+ years old, and has very limited computer skills… not so easy - or rather impossible - to make such a person change to newer software which does support current day codec’s…

Anyway, hoping Sam can solve it software wise as mentioned in the other thread.

@LeoB Forgive me if I missed this, but have you checked to see if your h.263 files will play correctly if you entirely disable hardware acceleration for MPEG4? There may not be enough CPU power available to play them smoothly in software, but it’s worth checking.

Do they have the option to export it to MPEG-2 which is a much more common format?

Did that fix involve just rendering it without the hardware decoder? If so, I think Full HD might be a bit too much for a 4K. If your interested and wanted to pm me a link to a problem video I could test it on a Vero V which has more CPU for performing such tasks.

With hardware encoding in handbrake on just an Intel iGPU you might be able to re-encode a full movie to AVC in just a few minutes even on a laptop. It may be worth looking into further.

@angry.sardine @darwindesign I did try disabling the hardware decoder. The H263 file from Pinnacle Studio (11 mbps, simple@L5) plays ok. The file from the Casablanca (15 mbps, high@L4.1) plays very choppy (3-4 seconds no or frozen image, then it syncs again, 1 or 2 sec normal image, then freeze or choppy, etc) so completely unusable.

Now that I know that the H263 is the issue, I have already asked the user of Pinnacle Studio to check if he can export H264 (or MPEG2, but then with a bit higher bitrate for quality reasons)… I cannot believe Pinnacle cannot do H264 (unless he is still using a version from the middle ages).

I will have to jump over to the home of the Casablanca user, to check myself what export options there are in that software… he is not skilled enough to find that out himself.

I have a powerful editing machine here at home (editing 100mbps 4K in multilayer without any problem), but I prefer not to drag along my laptop for the club gatherings. The backup solution is to take out our old Medi8ter Mediaplayer (15 yrs old or so, retired when Vero4K+ came in), which plays that H263 file perfectly… also a really basic-basic old laptop with a Pentium Dual-core T4500 plays it without any problem. I find it weird that the Vero4K+ cannot handle it.

It is not really weird that a hardware decoder would have issues with some of these transitional codecs. Those encodes I believe tended to vary in how they were done from software to software kind of like xvid did. As for the CPU on a 4K not being able to handle what a dual core Pentium can… why don’t you slow down that Pentium till it only uses a few watts and can be passively cooled and see how well it renders that video. :grin:

Fair point on the Pentium.
But the passively cooled (ok, an i audible mini fan if i remember well) 15 yr old Medi8ter mediaplayer plays it without a glitch… one expects to move forward, not backward with new hardware.

At some point one must come to terms that video output from an Amiga isn’t going to enjoy the same amount of testing and backwards compatibility fixes that it once did. That is why I mentioned MPEG-2 as it doesn’t tend to suffer the compatibility issues that various forms of h.263 do and one may find support as it predates that codec.

1 Like

If you can send me a sample, I’ll see what can be done.