Vero4k, Kodi 19 and add-ons

Since updating to Kodi 19, I’ve been having issues installing add-ons from the repository.

For instance, zap2epg, which was causing me issues, requires xbmcswift2 to work. Unfortunately, I could not install it from the repository. I ended up downloading the zip file and manually installing it, which worked.

I’m noticing that almost any add-on I try and install fails. Is there anything I can do to fix this issue?


Are you installing from the official repository?

From your last post, you didn’t seem to provide any logs, so we are still none the wiser


As far as I know I am. Sorry, here’s a link to my logs.


Strangely you have an issue with your Kodi logs.
Can you try to just upload the Kodi log. Otherwise please check via command line what might be wrong with the files.


The Kodi only logs are at:

I don’t know what command to run to see if anything is wrong with the files.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Okay, log is at

I couldn’t get it to recreate the original issue, which was:

I couldn’t get zap2epg to work properly. It turned out it required xmbcswift2 and it wouldn’t install automatically. I tried installing from the Kodi repository and it failed. It did not give me any info beyond “install failed”.

On the advice of the author of zap2epg, I downloaded xbmcswift2 from a mirror at Index of /osmc/osmc/download/kodi/addons/matrix/script.module.xbmcswift2/ installed that, which seems to have worked. I could now run zap2epg and actually, when finished running, it would say that it successfully did its thing. If I went to /home/osmc/.kodi/userdata/addon_data/scriptmodule.zap2epg and looked at the file xmltv.xml, sure enough, the epg was there with stations, shows, times, etc.

I then went to integrate zap2epg into TVH to use as the EPG Grabber Module, but it isn’t in the list.

I ended up uninstalling zap2epg and TVH and removing any newly orphaned dependencies. I then reinstalled TVH and then zap2epg. Zap2epg still won’t show appear in the TVH web interface.

You can refer to TVH on Vero4k · Issue #42 · edit4ever/script.module.zap2epg ( which is the correspondence I have going with zip2epg’s author. I have not implemented the last suggestion about permissions as I don’t know how to and also I’ve found it always a problem if I try fixing things from several different angles at the same time. Either I make it worse or I don’t know how I fixed it.

Any help is appreciated.

Strange,because based on the logs the dependency was automatically resolved

2021-08-02 14:43:53.128 T:2710    DEBUG <general>: ADDONS: found dependency [script.module.xbmcswift2] for install/update from repo []
2021-08-02 14:43:53.305 T:2710    DEBUG <general>: CurlFile::Open(0xe7fca420)

@fzinken I don’t honestly know. The zap2epg author did surmise that perhaps his add-on used some capital letters in the instructions to download xbmcswift2 and had subsequently fixed/changed it.

That’s my best guess as to what happened, but it remains that zap2epg won’t insert itself into TVH and become available as an epg module. I’m hoping something in the log will point to what is happening.

Well as it was told in that thread you had there going you would have to check if you have the file tv_grab_zap2epg in /usr/bin and what permission owner it has.

Open command line (see below) and run ls -lah /usr/bin/tv_grab_zap2epg and show us the output.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Never seen/used zap2epg but have you seen this error in the logs?

2021-08-02 14:44:44.963 T:3036    DEBUG <CAddonSettings[script.module.zap2epg]>: trying to load setting definitions from old format...
2021-08-02 14:44:44.995 T:2702    DEBUG <general>: Skipped 5 duplicate messages..
2021-08-02 14:44:44.995 T:2702    DEBUG <general>: DoScan Skipping dir 'nfs:// - Sex, Lies, Audiotape/' due to no change
2021-08-02 14:44:44.999 T:3036    DEBUG <CAddonSettings[script.module.zap2epg]>: trying to load setting definitions from old format...
2021-08-02 14:44:45.045 T:2702    DEBUG <general>: Skipped 2 duplicate messages..
2021-08-02 14:44:45.045 T:2702    DEBUG <general>: DoScan Skipping dir 'nfs:// - Sex, Lies, Audiotape/Cover/' due to no change
2021-08-02 14:44:45.056 T:3036    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                               Error Type: <class 'TypeError'>
                                               Error Contents: function takes at most 2 arguments (4 given)
                                               Traceback (most recent call last):
                                                 File "/home/osmc/.kodi/addons/script.module.zap2epg/", line 79, in <module>
                                                   check_status = check_load.raise_for_status()
                                                 File "/home/osmc/.kodi/addons/script.module.requests/lib/requests/", line 943, in raise_for_status
                                                   raise HTTPError(http_error_msg, response=self)
                                               requests.exceptions.HTTPError: 401 Client Error: Unauthorized for url:
                                               During handling of the above exception, another exception occurred:
                                               Traceback (most recent call last):
                                                 File "/home/osmc/.kodi/addons/script.module.zap2epg/", line 81, in <module>
                                                   dialog.ok("Tvheadend Access Error!", str(err), "", "Please check your username/password in settings.")
                                               TypeError: function takes at most 2 arguments (4 given)
                                               -->End of Python script error report<--
2021-08-02 14:44:45.056 T:3036    DEBUG <general>: onExecutionDone(21, /home/osmc/.kodi/addons/script.module.zap2epg/

This is what the command you asked me to do spits out:

-rwxr-xr-x 1 root root 1.6K Feb 7 2019 /usr/bin/tv_grab_zap2epg

I did see about the file permission comments in the github forum, but I wanted to try and fix this one step at a time. I’ve always found that if I try and do fixes from many fronts at the same time, it often screws up worse.

I don’t know entirely what I’m reading, but I don’t like the TVH access error. I know the username and password are correct.

I’m really hoping I don’t need to wipe the whole device and start from scratch.

So, start a browser on your PC and enter

as long as your TVH configuration requires a username+password, you are asked for it before the result is returned. By that you could check whether username+password are the ones you think they should be right.

I’m embarrassed to say the username & password were not there. I guess in my repeated uninstall/install sessions, I forgot to add it the last time.

Nonetheless, fixing the username/pword doesn’t seem to have helped with getting zap2epg to appear in TVH’s list of EPG Grabber Modules. I guess it is indeed an issue with permissions. I’ll have to wait until I find out how to deal with that (question is above at Vero4k, Kodi 19 and add-ons - #11 by fzinken)

So, give it a try to provide new logs.

Okay, I turned on logging, rebooted twice, and then re-ran zap2epg. The username and passwords were still there, but it asked me to fill in information about my location (to get the right EPG) that I know I have already inputted.

Anyway, the resultant log file is at

FYI, as of yet, I have not messed with permissions.

Oh yes, I check the web interface of TVH and still no sign of zap2epg in Configuration → Channel/EPG → EPG Grabber Modules.

Looked at the logs and any location of “zap2epg” … it seems now without any error/exception. I think you have to contact the developer of zap2epg what’s going on and why you do not find the expected epg grabber module within tvheadend.

Permissions look right.

You could try chmod 777 /usr/bin/tv_grab_zap2epg as someone wrote on the other thread but I doubt it makes a difference.