Vero4K loses http connection and reappears | Fhem-Server Notify

Hopping from one problem to another, I recently setup my Fhem-Server which controls my Cinema-Light in my room. I created a notify in the Fhem Controlcenter, which automatically detects KODI commands such as ‘play’ ‘pause’ and ‘stop’. This gives me some very convenient and cool experience on filmstart and at the end of any movie, or during a short break.

Altough, the Vero loses connection continuously and everytime the device reappears in the Fhem-Server, it turns on the lights. That should not happen since i dont want to have lights turned on every 2 min…

Has anyone an idea why this could happen? It seems the device loses websocket connection.

I’ve seen this issue with Kodi before but I’m not sure why.
I think it is a Kodi bug unfortunately. Maybe it’s improved in v18. @gmc – have you had reports / can you replicate this with v18 builds?


On my RPi Libreelec builds on Kodi V17 this wasn´t a problem at all. Fhem-Log says ‘lost connection to KODI device for 120 sec’, after that the Vero appears again and it says ‘lost connection to KODI device for 120 sec’ again, and so on and on… This happens as long as I connect the Vero4K to the Fhem-Server.

Do you see similar issues with Chorus?


Just tested it by playing some random video files in Chorus Web Player, and it aborts too after nearly 2 minutes.
Any solution to this?

It seems the Vero closes the http connection continuously, is it a bug in the OSMC build? Since this wasn´t the case in any of the milhouse builds on LE (RPi3).

Milhouse builds are Kodi v18 based
I thought you had tried with v17 on Le.

Try a v18 build on Vero 4k. I think there are some web server issues in v17


There were also milhouse builds on Kodi v17, which i had running on my RPi3. No issues there.

Will try v18 build soon…

Edit: Can i restore my recent Kodi v17 Backup in Kodi v18?

If you upgrade to v18 with your current profile everything will be kept and just the database will be upgraded to V18 version. Just keep a v17 backup in case you mess up on v18

Ok seems familiar. Thx!

Nothing changed in v18 exept for chorus, which seems to be running smooth without error. Still http connection loss on Fhem-Server. On RPi3 btw it´s running just fine, no issues there.

It´s getting a bit frustrating as I can´t make out where this issues come from…

Tell me if you need some log files, just in case someone is interested investigating special problems.

If Chorus works OK then JSON-RPC (handled by Kodi) is functioning as expected.
I’m not sure why Fhem-Server would have issues.

Is there a way for me to trivially install and reproduce?


That would be my guess too. It´s not a Fhem-Server Problem for sure.

I don´t think there is an easy way to reproduce, I mean you could setup a fhem-server and create some Kodi related notify via the web-interface… but this requires some read-in into the world of Fhem.

What makes you sure of this if Chorus and Kodi’s JSON-RPC is working OK?

Unfortunately I don’t know anything about this, so it may be hard to track down here. I assume Pi and Vero 4K are both connected in the same way to the network (wired) and running the exact same version of OSMC and Kodi?


Because the exact same functions did work without any harm on LE Kodi - RPi3.

Pi runs on LE, i could try to install OSMC and give it a look if its gonna work. Wiring is the same on both devices.

I’m saying that if Chorus works OK on OSMC, then JSON-RPC should also be OK.

Yes, it should. But something is broken in OSMC build…

We don’t make any changes here that would cause it to differ from other platforms.

So you’re saying JSON-RPC is completely broken, i.e. Kodi smartphone apps do not work? Have you tried Yatse / Kore / Official Kodi remote?

It may be tricky to get to the bottom of this because I’m not sure how to set up a Fhem server.

Trying OSMC on RPi soon, then we can compare things. Not saying its completely broken since Yatse and Chorus are working fine.
Also asking in the Fhem-forum, maybe someone knows if there was a change in server settings…

Feedback tomorrow…

If Yatse and Chorus work, then the OSMC and Kodi side is working.

Just tested Chorus again, NOT working as expected, seems it loses connection too. I started playing a file, then paused the video. As I wanted to continue, the unpause button didn´t work anymore.
Is there a proper way to find out if Chorus works?