Vero4k Netflix Add on - many films in 540p only

#1

Hi,

I have Netflix 0.15.2 installed on a Vero4k, along with the latest (mandatory) widevine libraries.

Many of the films are only available in 540p; the same content, viewed from a Roku Express, is either in 720p or 1080p.

Is there a DRM component on certain films (maybe tied to certain distributors) which causes this?

Changing the Inputstream Addon Settings makes no difference - switching from Auto to Manual simply streams the films in 240p; the affected content is shown in the selection list as 540p

Any insight is gratefully accepted.

Thanks
RR

#2

after you’ve selected ‘manual’ for Inputstream, start playback and go to video settings in the Kodi osd, you should then see the available stream resolutions…

Although 1080p playback struggles on the Vero, 720p is likely to be as high as you can go.

1 Like
#3

I’ll give that a go, thanks

#4

Hi,

I’ve now tested this approach; sadly, whilst it does allow selection from multiple streams, the highest resolution is 480p.

It seems the majority of films available from Netflix’s ever-dwindling catalog are somehow capped at SD resolutions when viewed via the kodi add-on.

Thanks for the suggestion though,
RR

#5

TBH I dont use Kodi for Netflix on my Vero anymore, I just use the app on my TV so I can get all the 4k content as well, same goes for Prime.

1 Like
#6

My 21" lcd is old enough to pre-date Smart TV’s!

#7

I think only Netflix content can come in 720p/1080p on Widevine L3.
Other studios insist on 480p max.

#8

Hi Sam,

Unfortunately it’s not that simple.

Many films, including The Terminator, are in 1080p (which I watch in 720p due to the use of the software decoder)

Cheers,

RR

#9

Then you should be able to watch them in 720p.

I’m not quite following

Sam

#10

The problem is the majority of content is 540p (480p in reality) only. Some films are 1080p. Most aren’t

#11

That’ll be Widevine restricting you

1 Like
#12

Don’t know if this might have something to do with it but there is a “new” setting under expert in Netflix add-on: “Limit videostream resolution to” set that to 720p and see if that helps, i got Killjoys last episode to play in 720p. And inputstream add-on settings settings to 720p on both resolution options.

I don’t know what the default resolution is, since it’s not shown until you set it.

#13

This may have changed recently, but the last time I looked, the better option was to set “general decoder” to “Max” and “secure decoder” to 720p. That way you limit Netflix to 720p but allow up to 4K on YouTube.

#14

That might be better, since i don’t use youtube on Vero4k. I have no experience with it