Vero4k no longer sees SMB or computer

Good afternoon,

I have the Vero 4k+ and it was working very well. Went to use it today and could no longer access anything on my library. Library is via SMB to my desktop on the same network, I tried opening it back up to SMB 1 protocal, tons of other troubleshooting options as well. SMB protocol to None etc. it gives me connection timed out even if I used computer IP address/ username/pwd.

Any other suggestions, starting to think I am going crazy here as the VERO doesnt even see the smb network anymore.


What device are you trying to connect to?
What operating system does it run?

Do you have a static IP address on your network?

Has anything recently changed in your environment?

Hello sorry. let me add some more detail- Currently running windows 10 Pro. Connecting from a Vero4k+. Static IP on both the Vero and the Desktop. Latest change was maybe 2 weeks ago I went from Wired to wireless on the desktop but it was working fine post change.

I tried creating a new user etc just to see what was up but that didnt fix it. When I go to connect it says connection timed out (if I go by my desktops IP) if I try by desktop name I get connection refused- I have triple checked the login ID and pwd that I always have had. I also deleted my video sources and started from scratch but it doesn’t connect/ see anything

Also thank you for quick reply

I would assume a recent Win10 update disabled smb1.
Suggest to start investigation from command line.
Connect to OSMC by ssh and install smbclient.
sudo apt-get install smbclient
smbclient -L <IP of desktop>

Ah cool will try that. I went into the windows menu and re-enabled all the smb1 check boxes. But I will try this approach too

You mean on the Win10 machine?

Anyhow let’s try to figure out what smbclient reports.

At one time it might actually make sense to say goodbye to SMB1 which is pretty outdated.

Thank you just installed, when we say smbclient -L do I leave space between L and my IP?


Connection to failed (Erro

I did the IPCONFIG on command prompt and checked that it is still correct static IP. Also went in and confirmed there are drives being shared and it is setup for “everyone” on network to see shared drives

Doesn’t look good.
try smbclient -m SMB3 -L

Who is “everyone”? Have you explicitly added the user you use from OSMC to the list?
Maybe than also try
smbclient -m SMB3 -U <user> -L

Still got timeout from first command
smbclient -m SMB3 -L

connection to failed (Erro r NT_STATUS_IO_TIMEOUT)
osmc@lvngrm:~$ smbclient -m SMB3 -L
WARNING: The "syslog" option is deprecated
Enter osmc's password: 
Connection to failed (Error NT_STATUS_IO_TIMEOUT)

osmc@lvngrm:~$ smbclient -m SMB3 -U kodi -L                       
WARNING: The "syslog" option is deprecated
Enter kodi's password: 
Connection to failed (Error NT_STATUS_IO_TIMEOUT)

So I created an admin level user for kodi. Added it to shared drives as well just to do eliminate that as possible issue
It went from working perfect to not, there must have been a windows update that has messed up a setting that I’m not seeing. It’s almost as if the computer isn’t allowing anything to jump on it

I would also add I can still Remote Desktop into my desktop so it is allowing other connections and plex is still streaming (other side note- not sure if relevant- under upnp plex was visible on the network from the vero

Edit- so I can’t add any more replies for 22 hours because I’m new but I pinged and got

PING ( 56 Data bytes

Edit 2: Nmap scan report for
Host is up.
All 421 scanned ports on a
re filtered
Edit 3: Connecting to at port 445
Connecting to at port 139
Connection to failed (Erro

Edit 4- weird still cannot make new post but I tried the ip addr and ip ro

IP ro-osmc@lvngrm:~$ ip ro
default via dev eth0 dev eth0 proto kernel sco
pe link src dev eth0 scope link

Ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 4096 q
disc noqueue state UNKNOWN group default

link/loopback 00:00:00:00:00:00 brd 

inet scope host lo
valid_lft forever preferred_lft f
inet6 ::1/128 scope host
valid_lft forever preferred_lft f
,LOWER_UP> mtu 1500 qdisc pfifo_fast sta
te UP group default qlen 1000
nk/ether 10:d0:7a:b1:c0:00 brd ff:
osmc@lvngrm:~$ osmc@lvngrm:~$ ip ro
-bash: osmc@lvngrm:~$: command not found
osmc@lvngrm:~$ default via d
ev eth0
-bash: default: command not found
osmc@lvngrm:~$ dev eth0 p
roto kernel sco
-bash: No such file or d
osmc@lvngrm:~$ pe link src 192.168.1

I’ve never had to open a port internally before on my network to access smb drives I am sharing from desktop- is that something I need to do? Such an odd thing to have it go so haywire

I still think something fundamentally wrong. The only time we have seen someone with that issue he in the end reinstalled the Windows machine.
Anyhow would start to dig in further.

First check which ports are open on your windows machine.
sudo apt-get install nmap
nmap -Pn -p 80-500

Second run smbclient with high debug level (be careful that will give many many information and you will have to check through it.
smbclient -d 10 -m SMB3 -U kodi -L

1 Like

Have you tested that you can ping the windows system from the Vero?


I overlooked your edit. So I just made you basic user you now should be able to make new posts.

Ok so thats either means the firewall is totally locked on the Win10 machine or you have a network issue.

What is output of ip addr and ip ro on OSMC?

1 Like

Not sure if Windows update reset some permissions.

  1. Did you check firewall?
  2. Did you check shared folder if it’s still sharing?
  3. Network and discovery, file sharing are enabled?

Maybe you can check this post and go to heading named “Some Things to Check to Make Sure You’re Sharing”