Vero4k not powering up


Bought an Vero4K in April and been using it occasionally. Last night wanted to use it (it was unplugged for a while), and now that I plug it in it doesn’t turn on. No red or blue light or sound, like it had no power at all. Tried with a different power supply and power outlet, but no luck :frowning: any recommendation on what it might be? or any test that can be done?


Can you take a photo of the power supply you’ve been trying to power the device with?



Hi valebv,
I know it has been a year since you posted this but I ran into the same problem recently. Any luck fixing this issue for you?


I have been using only the original adapter.

12V? Are you sure you are also having a Vero 4k?

Vero 4k+

That also is shipped with a 5V Power Supply, 12V can damage the device

But this is the original adapter i got with the Vero 4k+

Did you buy your Vero from someone second hand or from an unofficial seller or did you swap the power supply with one from an other device by accident?

The power supply I got with my 4k+ i bought from the store attatched to this forum looks like this :

That isn’t an official adapter. We don’t manufacture or sell this PSU anywhere, so you must have mixed it up with something else. Using this power supply would damage the device.

Dear Sam!
Thanks for the reply. I have looked thrgouh all the electronics and cables and found the proper adapter, it was mixed up with something else.


1 Like