Vero4k not turning off

I have my NAS mounted via a NSF share on startup and when the NAS is on the Vero4k turns off as it should.

But sometimes I use the Vero4k with a usb stick without it being connected to the NAS. Since the June update, when I use the Vero4k without the NAS, the Vero4k just freezes when I try to turn it off and I have to disconnect the power cable.

Before the June update, there was an brief error message about not being able to unmount the NSF share, but then it continued to turn off.

The device doesn’t implement ACPI. You’ll need to shut it down then unplug it.

Do you have any of your artist information folder or some other settings type of file that Kodi would be trying to access stored on this NAS? Can you post some logs.

I haven’t any artist information folder or other settings on the NAS that I know of.

Here are some logs: The first one is uploaded after a successful shutdown when the NAS is on:

The second log is uploaded after I had to shut down the Vero4k by disconnecting the power cable, because it froze the moment I selected shut down in the menu. The shutdown menu is still visable and the red LED on the Vero4k doesn’t turn on. The NAS was turned off and a usb stick with movies was connected. The LED on the USB-stick is still turned on after the vero4k freezes.

In My OSMC is your NAS set as a backup location? If you disable any backups or checking for updates in that add-on does this behavior change?

I disabled all backups and checking for updates was already disabled, but it made no difference.

I noticed that if I disconnect the network cable from the Vero4k when I turn it on, it will turn off without a problem.

I’m not sure if this is grasping at straws or not but you might try switching the mount over to autofs. The setup you have now with fstab expects the mount point to be there all the time but fstab doesn’t.