Vero4K occasionally stops playback & freezes

File being played in a 1080p H264 over NFS protocol (ethernet). The video will play normally and randomly stop, but not freeze. When the video stops, I still have access to the controls. Upon “stopping” the playback, OSMC will freeze for a while before actually stopping playback. I am able to re-play the file immediately after.

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Tom

Does it happen with one specific show / film, or everything?

I will do this asap and see if the issue comes up again. Another issue I ran into was pausing the video and then keeping it paused for an extended period of time (~1 hour?). When I came back, the Vero4K was frozen and did not respond to any controller (or TV remote via CEC) input.

I have only tried playing this TV series on the Vero4K so far, which is encoded in 1080p h264.

Any news on this ?
I have the same kind of problems, except that the freezing is systematic over NFS shares.
The NFS itself is working well, I have it mounted on another computer, and copying one entire mkv to local disk takes less than one second.
Still the video will freeze after e.g. one minute.
Accessing the very same file by ftp works great.
I’ll activate the logging as suggested…

That must be a tiny file are it must be this be Petabit Ethernet

tiny file (20 mns). Hence my point: the vero 4k manages to freeze on that small file.

Well first test then to copy the file to the internal memory and play from there to see if it is network related.

If it plays from the emmc than provide mediainfo and logs so that we can help

I’m not sure to understand everything, but as I said I played the very same file from ftp without any problems. I guess it rules out any media problem…

Well then it sounds like a specific nfs problem. Than my recommendation would be first to either try to change nfs version or try an alternative way to mount nfs on the Vero e.g. Fstab or autofs

change nfs version

You mean the client or the server ? The server is a synology NAS…

try an alternative way to mount nfs on the Vero e.g. Fstab or autofs

I’ll have a look, but using NFS should be straightforward, and if I have this problem likely others will have too.

Thanks for your quick help !!

Server would be my first try.

Well we haven’t seen many reports about it. Which either indicate it is specific to the client/server situation or that most people who use NFS use either fstab or autofs

Server would be my first try.

Yes but because it is a proprietary NAS it’s not that easy to control the version.
Moreover the NFS is working really great on my computers.

Thanks again.

It’s possible the connection is dropping. Kodi doesn’t tolerate this well. This could be mitigated through the use of AutoFS.

Really? I don’t own one of these but after an exhaustive multi-second search I seemed to have stumbled upon information that would seem to contradict that difficulty claim…

https://www.synology.com/en-us/knowledgebase/DSM/help/DSM/AdminCenter/file_winmacnfs_nfs

Yes you’re right about NFS protocol version. I thought you mean version of the APT package.
I have nfs v4.1 enabled though.

I followed your suggestion and configured autofs with options-fstype=nfs4,rw,noacl,noatime,noacl,nodiratime,rsize=32768,wsize=32768
and for now it seems to behave much better.

Regards,