Vero4K playback issues after June Update

This week I upgraded my Vero4K to the latest June release. Once updated I noticed that I could no longer play nearly all of my videos. The video would start for a second but then immediately stop. If I retried a few times sometimes I could get the video to play. However quite a few of the videos just would never play. I went back to previously watched videos that were OK and these would also not play.

General Setup:

Vero 4K - Connected via Ethernet cable to Synology DSJ. Using an SMB network share. No previous problems using all images up until June release.

Things I’ve tried to fix it

  • Reset Kodi from with OSMC - No change, still broken
  • Reinstalled Vero4K image from June release - No change, still broken
  • Reinstalled Vero4K image from March release - Works correctly with all media tested

Before I downgraded the OS image I took a log which shows the issue

The following extract I believe shows the issue:

DEBUG: Thread BackgroundLoader 3144676064 terminating
2020-09-27 17:00:25.460 T:3961696992   DEBUG: DoWork - took 309 ms to load special://skin/extras/backgrounds/1.jpg
2020-09-27 17:00:25.607 T:3132556000    INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)
2020-09-27 17:00:25.930 T:3680830176   DEBUG: Open - avformat_find_stream_info starting
2020-09-27 17:00:25.932 T:3132556000   ERROR: Read - Error( -1, 103, Software caused connection abort )
2020-09-27 17:00:25.932 T:3132556000   DEBUG: CFileCache::Process - Source read returned a fatal error! Will wait for buffer to empty.
2020-09-27 17:00:25.932 T:3132556000   DEBUG: Thread FileCache 3132556000 terminating
2020-09-27 17:00:25.933 T:3680830176   DEBUG: ffmpeg[DB6502E0]: [mov,mp4,m4a,3gp,3g2,mj2] Could not find codec parameters for stream 0 (Video: h264 (avc1 / 0x31637661), none, 720x400, 1090 kb/s): unspecified pixel format

Has anyone had anything similar? It looks like a network buffering or socket timeout issue of some kind but I have no idea of what settings to tweak.

I’m happy to try any changes or submit extra information etc.


Try enabling the mitigate SMB issues option under Settings -> Services. I suspect your NAS does not implement SMB correctly.


Thanks. I just saw that in the June thread. I’ll give it a go. Sounds like its the same issue so hopefully will fix it.

Sorry, I re-installed the June release but I don’t see the option in any of the sub menus. I’ve switched to expert mode. Could you please advise. Do I need to install a special version?

Edit: Ignore this. I just manually updated it and I can see the setting now. I thought it was added in the full June release.

It’s under Settings -> Services -> SMB