Vero4K - Realtek USB3 Ethernet Adapter no longer supported?

Log Files -

I was having lag issues playing a file, so I began an investigation.
iPerf3 showed only 280Mbps downstream on my Vero4K with the recommended USB3 1Gbps Ethernet adapter from Realtek.
(I also have a Vero4K+ on the same switch…it performs at 932Mbps. I eliminated possible cabling issues and switch issues.) And I tried switching USB ports.

Dmesg shows some concerning errors such as
[ 2.563938] usb 1-1: New USB device found, idVendor=0bda, idProduct=8153
[ 2.563944] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[ 2.563948] usb 1-1: Product: USB 10/100/1000 LAN
[ 2.563951] usb 1-1: Manufacturer: Realtek
[ 2.563954] usb 1-1: SerialNumber: 000001
[ 2.573339] usb 1-1: Unsupported device
[ 2.573607] usb 1-1: Unsupported device

[ 2.028922] xhci-hcd new USB bus registered, assigned bus number 2
[ 2.028976] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 2.029062] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[ 2.029067] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 2.029071] usb usb2: Product: xHCI Host Controller
[ 2.029074] usb usb2: Manufacturer: Linux 4.9.113-60-osmc xhci-hcd
[ 2.029078] usb usb2: SerialNumber:
[ 2.029509] hub 2-0:1.0: USB hub found
[ 2.029536] hub 2-0:1.0: config failed, hub doesn’t have any ports! (err -19)
[ 2.031380] usb usb2: Unsupported the hub

I could not find the Vero4K specs onsite, but I see the 4K+ specs show USB2 ports.
So now I cannot remember for sure what speeds I use to get on the Vero4K with the Ethernet Adapter

…also the OSMC log uploader would not work, so I went with grab-logs -A


Verok4 is also only usb2, I wouldn’t expect any faster than that what you’re getting. USB3 gigabit adaptors are never going to get any where near a gigabit in speed on the vero4k due to usb2 bus speed, but they will be faster than 100 megabit lan port on board (although it should be more than capable of streaming most content).

Regards Tom.

280Mbps is about right for a USB adapter.


Thanks. I have have been trying everything for the last 2 hours to determine why files in that one directory take 5mins to load and will not play smoothly anymore.

The files are on my only Windows7 SMB directory, (all others drives are on Linux/NFS) but my SMB settings on the Vero4K and the Vero4K+ are identical.

I only recently switched the Vero4K to Matrix (19.3) , and I do not recall that “Unsupported device” error on the previous version…but checking the boot log is not something I ever had to do recently . This issue only began when I updated the Vero4K to Matrix a couple of weeks ago to utilize the shared MySQL database.

Guess I’ll have to abandon that drive and move the files to another server.

So I have not given up yet…

To summarize…I have 2 servers storing videos, 1 Linux server using NFS sharing, and a Windows 7 server with one directory holding Bluray rips. Some of the rips are in .iso format.
I have a Vero4K and a Vero4K+ on Kodi 19.3, and both have the same issue.

When playing an .iso from the Windows7 server, it takes very long to load and lags during play. (m2ts streams load quicker, but still much slower than before.)

At first I suspected the USB3 1Gbps Ethernet adapter, as the boot log reports it is not supported. I never saw that error with Kodi versions prior to 19.3.
However, iPerf3 tests are normal for a USB2 port (280Mbps)

I tried a Kodi 19.0 installation on a Windows 10 notebook…and it worked perfectly. .iso files from the Windows7 server loaded immediately, bluray menu options appeared and played normally.

There were only 2 changes made to my system in the last few weeks.

    • I updated 2 Veros, a 4K and a 4K+ to 19.3, and
    • I implemented the MySQL database sharing feature on the Linux server and the 2 Veros.

It was easy enough to disable the MySQL support on both Veros, but there was no improvement.

Next I drew my attention to the SMB Client configuration on the Vero4K. I changed the minimum/maximum SMB version from None/SMBv3 to SMBv2/SMBv2 and turned on the MTU feature. Activating the SMBv2 MTU feature did improve the load times for .iso files. Not a great improvement, but an improvement none the less.

Extracting the .m2ts stream from the .iso files made the most improvement. Loading times were more normal and no lag. However when using the “Clean” video function, it does not find the Windows7 shared folder, and asks to remove it. Strange, since I can now play those files.

My next step is to load Wireshark on the Windows 7 server and capture exactly what is going on.


Another test would be to see if kernel mounts over kodi libmounts, play better. Autofs is the easiest way to do this:

Thanks Tom.

You know , while reading your post it occurred to me that I only had the NFS shares mounted via fstab.
I’ll add the SMB share and see if that helps.

I was reading up on these SMB issues on the forum.
It is getting quite ugly over there…lot’s of complaining, insulting the devs, but not a lot of cooperation into helping resolve the issue. Glad we do not have that attitude here.
There was mention of a “fix” coming in version 20.


1 Like

All my shares (NFS & SMB) are now fstab mounts. /mnt/fred_drv1        nfs     noauto,x-systemd.automount  0  0 /mnt/fred_drv2        nfs     noauto,x-systemd.automount  0  0 /mnt/fred_drv3        nfs     noauto,x-systemd.automount  0  0
// /mnt/drv4/ cifs username=SMBuser,password=SMBpassword,dir_mode=0777,file_mode=0777 0 0

Not a huge improvement loading .iso files, but enough that I can call this solved.

Extracting the .iso files to the Bluray folders and .m2ts streams does remove the loading time issue and the lag issue while playing.

1 Like