Vero4K red light, no ethernet, remote usb adapter not working

I have a feeling the unit is on deaths door, not sure what else to try

It is showing continuous red light, the power supply works fine on another Vero4k and have tried a few other working power supplies and even USB power, but still just a red light.

Ethernet is also not working, and does not get a link light on the switch, have tried multiple ports and cables, I can get a connection by using a USB to ethernet adapter.

Could not get a response from the remote with a new battery, would not pair, used a dongle from my other Vero4K and it it worked with the remote.

I generated this log by booting up with just the ethernet plugged into the Vero4k’s port and the bad remote dongle plugged in, I don’t know if they will show anything on the logs, but thought it would be worth a shot. Once booted, I plugged in the USB to ethernet adapter and working remote dongle to be able to upload the logs

TL;DR background
This is my backup Vero4k that hasn’t been used in over a year, I recently reworked my media servers so I though it would be a good time to update the backup unit… but it booted to a cycling sad face, tried to install a new OSMC image from SD card and failed with a segmentation fault and then was stuck on a blank black screen.

I tried another install and was successful, but couldn’t get the remote to work until I switched the USB dongle, then couldn’t connect to the network during setup, I had a USB to ethernet adapter around so tried that and it worked for completing setup.
I tried another install of an image from Jan2020, but same issues. I had it do the system updates and during the blue screen updating parts the light was blue, but after the update went back to red

Strangely, while it is booting, it shows up as “mbox meson ref” on my receiver which my other Vero4k doesn’t do

In general, the log seems ok, but is showing that the kernel isn’t detecting the built-in (gigabit) ethernet interface:

Feb 06 23:44:47 osmc kernel: libphy: stmmac: probed
Feb 06 23:44:47 osmc kernel: eth0: No PHY found

I seem to recall that @sam_nazarko said the gigabit ethernet takes quite a bit of power, so you might be operating with too little power, though enough to get most of the device up and running. As a long shot, a full software reinstall is also worth a try.

4K or 4K plus?

Both units are the 4K, not 4K plus.

Is there an image that would be better to test? So far I have tried:

Hmm. Take a look at your log, under the cmdline heading. It says:


Have you at any time installed the 4.9 kernel?

Not unless it was in one of the monthly updates.

Is there a way to reinstall forcing as 4K, instead of the installer which is 4K/4K plus?

Yes, probably. You would have known if you’d installed the 4.9 kernel, since it’s an experimental version. The mystery is why the device somehow thinks that it’s now a 4K plus.

The good news is that getting it back to a 4K should get the ethernet working again (and possibly fix the red light problem).

I think @sam_nazarko needs to take this one forward.

The Ethernet won’t work currently if the device believes it is a 4K + and the GPIO configuration for the LED is different, which is why you are seeing the permanent red light.

I need to think of the best way for you to fix this. Did you re-image the software with another OS at some point? It’s not clear to me how the wrong bootloader could have been installed on your device.

Try the following:

  • Connect to WiFi
  • Login via SSH and run (copying one line at a time)
sudo -s
dd if=/opt/vero3/uboot-vero4k.bin of=/dev/mmcblk0 conv=fsync bs=1 count=11
dd if=/opt/vero3/uboot-vero4k.bin of=/dev/mmcblk0 conv=fsync bs=512 skip=1 seek=1

OSMC should now come back up, and the LED should be fixed and Ethernet should work.

Now the final step, to ensure you get updates is to do as follows:

  • Power off the device
  • Find a non-conductive pin, such as a toothpick
  • Apply power and while doing so put it in the round port nearest the HDMI port. You should hear a soft, audible click
  • Wait for a few seconds (about 10 seconds)
  • Remove power and toothpick
  • Power up

Now, run fw_printenv | paste-log so I can check this was performed correctly


The first part fixed the ethernet and LED, booted fine and could SSH in

Powering up after the toothpick part resulted in:

"Waiting for root filesystem device /dev/vero-nand/root
FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected.

OSMC initramfs Rescue Console.
For help ans upport see
/ #"

Could not SSH in, but on the off chance this was expected, I attached a keyboard and put in “fw_printenv | paste-log” and got back

sh: sh: fw_printenv: not foundpaste-log: not found

I would recommend reinstalling OSMC now.
This should solve the issue


Reinstalling 2020.11-1, put it back to red light and no ethernet

Can you copy the ‘installer.log’ off the USB / SD you used to image and upload it to It’s unclear to me why the wrong bootloader is being installed

Can you also let me know your OSMC order #s so I can check what hardware you have?



The log is at:

I think it was order 14445, but might have been 18131

Okay, both should be Vero 4Ks from my records.

They should have both come in a blue coloured retail box, rather than a black one.

I don’t think the toothpick method worked as expected for you. So let’s try this:

Connect to WiFi and do this again:

sudo -s
dd if=/opt/vero3/uboot-vero4k.bin of=/dev/mmcblk0 conv=fsync bs=1 count=11
dd if=/opt/vero3/uboot-vero4k.bin of=/dev/mmcblk0 conv=fsync bs=512 skip=1 seek=1

Now boot, and run

sudo -s
fw_setenv initargs "init=/init console=ttyS0,115200 no_console_suspend earlycon=aml_uart,0xc81004c0 ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000

Now, you can reinstall OSMC and all should work as expected. Although a reinstallation won’t be necessary now

You should be doing all of this with the latest image on the website.

We’ll look at the remote dongle issue after that

And that worked perfectly!

After the reinstall ethernet still works and LED is blue. I looked at the install.log and saw it identified the right bootloader:
Sun Jan 1 00:02:18 2017 Vero 4K family: bootloader to be flashed is uboot-vero4k.bin

Perfect. Not sure how things got mixed up, but I’m glad this is now working.

So I understand your remote is now not working. Please try this:

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Plugging the USB back in doesn’t give the blinks until about 1 minute, but I think that is a timeout. I tried the 2 minute power off anyway, but still not paired.

The other dongle pairs up right away with either remote

It sounds like the dongle might be problematic. If you post a log with it connected, we can confirm if this is the case.

I enabled debug logging and rebooted, about a minute after fully booted removed and reinserted the USB dongle in each USB port to see if it appears
(it took a couple tries, dubug logging kept turning off with the reboots)

The dongle doesn’t appear to be detected at all.

Can you try it on a PC?