Vero4K Redlighted

Woke up this morning to a red light on Vero4K and no signal to display.
Device is cold to the touch.
Power supply is putting out 5.33Vdc.
Pulled all the connections and powered cycled.

Is there anything I can do, or is it done for?

A PSU can easily put out 5V when not under load then wilt when it’s powering something. If you don’t have anopther PSU handy, do you have a way of measuring the voltage on a USB cable plugged into the Vero?

Tried a USB cable and it worked.
Tried another PSU ( rated 5VDC-2.7A) and it worked.
So it looks like the Vero4K’s PSU gave up.

1 Like

Seems like these PSU’s that come with the Vero4K are not the most reliable.
I can’t recall ever having a PSU failing on any device.
But it a good thing I save them all even if the device is obsolete.
Old PSU’s come in handy to power external fans for audio/video equipment.

We are seeing about 3/100 failure rate after two years, which is pretty good for consumer electronics. Fortunately it’s an easily replaceable part.

We’ll improve this in the near future.


I see you have no replacement PSU on site, which is probably good as shipping costs to Canada are ridiculous these days.

Do you have the specs for a replacement?
I know it is 5.0V-DC, 2.0A, but I don’t know the plug size designation. ( 1/4" ? )

Edit: my measurements show 5.5mm x 11.0mm.

I think our replacement PSU price is reasonable for US/Canada. See here

Otherwise happy to provide specs.

Your price is good…but I managed to get 1 locally, with free next day delivery, for the same amount including the tax.
It’s not the price of foreign goods, that is hurting businesses, it’s our tax, brokerage fees, exchange rates, and shipping costs. Free trade is a myth in Canada.