Vero4k+ stop playing movies after a few seconds

Hi there,

First post in here, been a happy user of the Vero for about a year without any complains. However, I updated to the recent release of Kodi today and now I am unable to play my movies, it plays well a few seconds and then jobs back to kodi/osmc. I am steaming from a NAS. FYI I haven’t touched a thing, worked without any problems before the update and if I am playing the same movies on the plex add-on in kodi, it works fine.

A log from the issue is here; https://paste.osmc.tv/loluvohine

Appreciate any help or assistance.

Br,
Jonas

That’s not a full debug log.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I can add that the drives are added through smb and I am noting quite high cpu usage at idle, round 50%…

aha thought it was, is this one better? https://paste.osmc.tv/pukuyitelu

GUI Resolution: 3840x2160 @ 60p
Adjust display refresh rate: Off

The first thing I see is that you have the GUI set to 2160. Set it to 1080 and Adjust display refresh rate to On Start/stop

If that doesn’t help, the next step would be to try system mounts (fstab/autofs) instead of Kodi mounts.

I’m not sure why you wouldn’t have ran across this issue with the July update but it sounds like perhaps it could be related to [this].

I see your current settings at Settings>Services>SMB Client are…

<setting id="smb.legacysecurity" default="true">false</setting>
<setting id="smb.maxprotocol" default="true">3</setting>
<setting id="smb.minprotocol" default="true">0</setting>

If your NAS supports SMBv3 then set that as both the min and max protocol and reboot. If your NAS does not support SMBv3 then leave that setting alone and enable the “Mitigate MTU issues…” option and reboot. If this is the issue a system mount will also work around the problem and give a network speed increase as well.

1 Like

Great thanks to both of you, works with the quick fix you mentioned darwindesign. I haven’t updated the vero for some time, as it was working like a dream. Will fix system mounts later on to increase the speed somewhat. Again thanks.

1 Like

Did you also change the GUI to 1080? It will look better that way.

I did but if I do so the “bar” at the left hand side, with the option to update library etc is not fully visible at my TV, which it is at 2160. May I ask why its better that way?

You need to turn off overscan on your TV. Depending on the TV it could have different names. Just Scan seems a common name for the option.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I very much appreciate the great support in here. I will update my settings as per your recommendation. Thanks.

If you have difficulty finding the overscan setting on your TV, let us know the make/model and we should be able to help you find it.

Unless you have connectivity issues which method you go with is probably irrelevant but instructions for each…

https://osmc.tv/wiki/general/mounting-network-shares-with-autofs-alternative-to-fstab/

And to actually use them you will have to dump your library and add new sources or else take the path of least resistance and just put in a path substitution to redirect to the system mount.