Vero4k+ stopped working after connecting USB drive

Today the most strange thing happened. Due to a NAS crash I thought I’d take one of the Lacie Rikki MS25U I had content on and put it in the vero so I could still access some of my data (fully aware of the fact that the vero might not be able to power the usb drive). When I plugged it into my vero - the vero died! I tried to power cycle it with disconnecting the power but it still did not seem to do much apart from a red light (the red cross). Please see picture.

It looks pretty bricked to me, is there anything I can do?

Does the drive have its own power supply?

That red light could indicate the Vero isn’t receiving enough power to boot.

Disconnect the hard drive and connect a USB A cable to the Vero and another device like a laptop.


It did not. But I disconnected it right away, so the issue is there without the drive. :confused:

I would suggest trying with a USB-A cable as suggested above and see if that helps.

1 Like

Actually - simpler test. You have two Veros, if I recall.

Try the power supply from the other Vero which is working.

Oh I did that first thing. Same issue.

Okay, the next steps to try would be to:

Try and reinstall OSMC.

If this fails, see if the device is detected in Device Manager when applying a USB-A cable to the white port of the device.

Nothing. Reinstall does not even seem to start, and then no device in device manager. Just a mean red LED that flashes so slightly about twice a second.
Edit. Its always on but “blinks” slightly about twice a sec.
Edit 2: I might have mistaken the 4k+ for the 4k. This could be the 4k. Would the mac help? Its c44e:ac09:6a36.
Edit 3: I know see that the “black” usb port in the vero is severely broke (the one I tried to attach the drive to), I must have broke it years ago without knowing/recalling. I don’t know if that could have cause the bricking but I guess there’s not much else to do than ordering a new one.

The white port would be used for OTG (i.e. to check it on PC).
I believe your device is a Vero 4K, but it should say ‘Vero 4K’ or ‘Vero 4K +’ on the bottom of your device by the MAC address.

You say the USB port is broken – is it possible something is stuck in the device / shorting? If you leave the device powered for a couple of minutes, is it getting warm?

Well both says Vero 4K but the other one (working one) says 4plus in the settings (somewhere under system info), and I’m positive I have one 4k+ and one 4k. I found my ordering mail for both so that’s definitely true.
I used the white one for the test, there’s nothing stuck in the black on but the “black” part is missing…stupid not recalling that. Maybe I shorted it, “blew it”, when inserting the drive?
It does not get warm but there’s a low, low scratching sound, like a mechanical drive sound but very low. I guess I have broken it and its 5 year old so…maybe it should quietly go to vero heaven.

There was a small batch of 4K+ devices at the start where we used the 4K label because we didn’t want to delay deliveries. The System Information page will be accurate, and if it says 4K+ then your other device is indeed a 4K.

As the device is so old – there’s not much you could lose from opening it gently with a butter knife and seeing if there’s anything obstructing inside the device.

If your NAS stopped working and then you plugged a hard drive from the NAS into another device and it died, I would think that their might be an electrical fault in the hard drive and I would be cautious about plugging that drive into anything else.

1 Like

Yes, and if I hadn’t previously broke the usb port I totally agree with you.

I will admit defeat and when I get my new NAS up and running I will order a new shiny 4k+. Thanks guys for your help.

1 Like

I opened it up and it looks ok apart from the usb port which looks in a right mess with connectors pointing the wrong way. I I mentioned I will admit defeat and I most likely caused this myself. Thanks for excellent attention.