Vero4K+ strange CEC behaviour



I’ve decided to create a thread here after searching the forums and not getting the right information.

With both my previous Nvidia Shield TV, as well as S905 box running Libreelec, CEC has always worked out of the box perfectly for my setup, namely, using my TV box remote to do everything I needed: power on projector and AVR, power off all devices, volume control for my AVR etc. Most importantly volume control my passthrough audio.

Similarly, I would like my Vero 4K+ remote to control my passthrough audio on my AVR but I can’t get it to work.

I have upgraded my projector early in the year to an Optoma UHD40 which seemingly does not support CEC so perhaps that is the cause of my problems. The AVR (Denon AVR-X1400H), HDMI cables, etc is all the same and known to be working and set up correctly.

I don’t mind getting my hands dirty, it’s just I have no idea what to do further.

For starters here’s what I see when I run cec-client:



I’ve always found implementation of CEC on Optoma projectors to basically be a write off when using an AVR.

I’ve found this with HD23, HD25 and UHD-51A.

If you run things to your AVR and another display as a test I suspect you’ll find things work.
Can you confirm that your Shield and S905 box with LE still work as expected on the new PJ? I’ll be surprised if this is the case, and if it is, it means it’s something we can fix.

I’ve mentioned this to Optoma. The UHD51-A supports OTA firmware updates, which is why I chose it over the UHD51 (I’m not interested in Alexa). So there’s some promise of a resolution in the future.

I assume you’re trying to control your volume with the OSMC RF remote controller?



Hi @sam_nazarko

I’ve had back and forth interaction with head of Optoma UK support and they were very ignorant of the facts that I have given them (about another, unrelated, firmware bug) so good luck with that. Their extremely poor level of support, and patronizing and condescending attitude only makes me appreciate it all the more that you are giving proper support for your OSMC hardware, so sincerely thank you for this, this is exactly why I bought into OSMC

I’ve since sold my Shield because the UHD40 couldn’t display standard 4K bluray content (10bit 4:2:0 YUV bt2020) properly without colour banding when the content was passed in 23.98 Hz at 12bit 4:2:2 YUV so again, Vero 4K+ wins the Shield in that department because it outputs the same 23.98 hz content @ 10bit 4:4:4 (YUV) bt2020 which my projector can display without banding.

Back on topic, my old Optoma HD142X worked fine with CEC, like powering on and off together with AVR controlled by Libreelec on a box with S905 chipset.

I can indeed confirm that out of the box the Nvidia Shield TV as well as my old Libreelec box can control volume on my AVR without any additional settings/tweaks, even on the new UHD40 projector as my display.

I am trying with both OSMC RF remote control as well as my favourite remote, the Xiaomi TV box BT remote (non-voice control). The latter worked straight away after pairing so that was really pleasant. I also attempted remapping volume control with Keymap editor but I assume it didn’t really change anything because it still tries to control the kodi volume, nothing with CEC that I can see.



Obviously I can’t comment with regards to your experience with them, but hopefully I’ll have more luck than you here. I can prove where CEC is being problematic in the chain, and it’s overwhelmingly on the Optoma’s end in negotiation and RX.

Can you upload debug logs from one of those systems, ideally LE as it’s Linux based, and then OSMC so I can compare things?

Can you also ensure that on both tests they’re connected to the same HDMI ports (both in to AVR and AVR out) as well as with the same peripherals attached to AVR/TV?




Hi @sam_nazarko

As per your request, I have swopped out the Vero4K+ with my S905 libreelec box, keeping the cables and everything the same. I used Vero’s remote on both, but on the Libreelec box I had to remap VolumeUp to the stop key with Keymap Editor for this test as it did not detect the volume buttons.

Vero4K+ logs:

LibreElec box kodi logs:

LibreElec box sys logs:

Test setup:

Box under test -> Denon AVR-X1400H -> Optoma UHD40

I pressed the relevant volumeup key.

On the Vero4K+ VolumeUp attempts only to control onscreen volume which does not affect passthrough audio because it does not control the volume on my AVR via CEC.

On the LibreElec box VolumeUp successfully sends CEC volume command to AVR as expected, AVR volume increases.

Thanks for your assistance


That’s odd. Are you using an old version of LibreELEC? Support was added to LE in February 2018.

Are you definitely testing on the same versions of Kodi (both 18.3)?


Hi @sam_nazarko

No - my Vero4K+ is fully updated and the LibreElec box runs an old community build.

The LibreElec box has the following version info:
OS: LibreELEC (community): (kernel: Linux 3.14.29)
Kodi: 17.6 Git:a9a7a20


Ah, that probably explains the difference. That LE build will have a much older version of CEC.

I will look in to it.


I’m not sure what CEC version you are talking about specifically, not sure if this is useful but cec-client outputs a version as “libCEC version 4.0.2”


Yes. We are on 4.0.4 here. Will check it out.

1 Like