VERO4K+ - update failed

Hello again !

My vero4K+, if my memory is OK, was working on the nov20 version with a special “old bootloader” (Mr Sam Nazarko helped me a lot, guiding me on how to flash the bootloader, …).

I tried to update through the myOSMC app, at the end of the process, a message told me that an error occured concerning vero3 bootloader. (I don’t remember the exact name of the package), and that the device would reboot in 30 seconds…

It did, but then nothing on the screen (no sad face, nothing). The front LED cross stays on, RED. (I waited 5 minutes, nothing)

Connected with USB cable to a linux PC, dmesg doesn’t show any sign of device detection, (the red light on).
(before the update: new USB device found, idVendor=1b8e, idProduct=c003, bcdDevice= 0.07

And on a windows PC with USB burning tool, nothing either…

Can I try something ??? (maybe sd card boot method, but which image ?? )

Thank you very much !!

The device may be in a boot loop if it doesn’t show up on a PC.

Just to confirm, the USB cable is attached to the white USB port?

To be accurate:

  • USB in white USB port : very fast red light (for like some milliseconds), then off
  • USB in black USB port : 2/3 : same as white; 1/3 : the red light stays on
    In both case, nothing detected in dmesg…

Should I try the tooth pick method with the latest image ?

The device may be in a boot loop if it doesn’t show up on a PC.

Just to confirm, you tried the USB cable on the white port?



Sorry. I don’t know how I posted this twice. I initially replied on my phone and then laptop.

I think the device is in a boot loop. It can be recovered but it would require you to open the box and short eMMC pins. As this is out of warranty, it shouldn’t be a problem.

I will give you some detailed instructions tomorrow. The process is very simple, but needs some time.


no problem !
Thanks again for answering and helping me bring that device back to life !
Great support !!!