Vero4K: want to use as PVR / view OTA broadcasting

Absolutely go with the quad in case you ever decide to subscribe to their Premium Service which occupies a tuner for each simultaneous channel you stream.
Another advantage to the Homerun is you can watch TV on your phones and tablets and if you run a Plex server on a decent computer (not your NAS), you can watch TV on your phone from anywhere you have an internet connection.

So, antenna is on the roof and 39 free OTA stations are coming in.

Bought and put in a HDHomeRun Duo which seems to be working fine. Unfortunately sometimes the sound and picture is out of sync. The TV, the HDHomeRun and the Vero 4K are all plugged into the same router, so I’m not sure what is going on there.

I have no clue how to get the PVR aspect of things running.

I followed these instructions and it seemed to do work. No errors were encountered.

After that, it sort of falls apart. I can watch live TV through the Vero 4K and there is a on screen guide that shows up, but I can’t figure out how to get it to record. My goal is to have recordings go to my Synology DS418j located elsewhere on the network.

I’ve poked around and can’t find step by step instructions to get this working. Any ideas or links?

You set up the recording destination in the TVH GUI. IIRC you may have to enable yourself (as the user) to be able to record but I thought it was enabled by default in the OSMC install.

To record from the EPG screen, click on the programme you want to schedule for recording and click record.

Or while watching live TV, press OK and look for the round record button and click on that.

Hmmm, I think this might be along the right path, but I haven’t got there just yet. I added the path in the Recording system path box of TVheadend (in my case it’s /diskstation/volume2/video/PVR)

But it doesn’t seem to work. On the NAS, there is a Vero4K user that has read/write permissions to the video folder. This video folder (parent of PVR) also has a movie folder that the Vero4K can and does access all the time without issue, so I don’t think it’s a permissions issue.

I read on another forum that you should, in the DSM (the NAS software) go to the permissions tab of the shared folder and choose “system internal user” and give permission to your TVHeadEnd account. Unfortunately, there is no such account listed.

Here’s what I’m seeing. This is the permissions given to the Video folder on my Synology NAS. Thinking since the user name in TVHeadEnd is osmc, I ought to make a user of the same name on the NAS. It didn’t work. The Vero4K user has always worked to view video files in subfolders of the Video folder.

Next, this is the configuration page for TVH. All seems okay.

This one is status of the connections - don’t like that red X. That IP address is my Vero4K.

Note, all this experimentation is being done from my Windows computer. Ultimately I want to be able to record, etc from the Vero.

is /diskstation/ a mount point on the vero? An NFS path would normally look like diskstation:/path/to/share.

The NFS path for the Vero to view movie files is NFS://ip of NAS/volume2/video/movies, so I followed that format and put in the same, except to the PVR folder.

Still doesn’t work, but something seems to be happening.

I’m sitting at my tv with my tablet logged into the TVH GUI. Using the Vero on the tv, I try to record something. The Vero says recording started, then immediately says timer deleted and that’s it. On my tablet, I see the recording pop up on the list and then immediately get a red X.

Under digital video recorder -> removed recordings, there are all the attempts the Vero tried to do the record. The status column for each removed recording is “file missing”


But in your screenshot, it says /diskstation/volume2/video/PVR. The notation NFS://ip of NAS/… is specific to kodi and will not be understood by tvheadend. I suggest you first set that path to a local directory (say /home/osmc/TVrecordings - create the directory first) and make sure it’s all working with that.

Then I suggest you mount the NAS recording directory in your vero’s filesystem. I mount mine at /mnt/nasdisk/TVrecordings for example. Have a look here:

I’m no linux guy, so bear with me.

According to the wiki you suggested, I added /- /etc/auto.nfs.shares --timeout 15 browse to the file auto.master.

For the sake of clarity, my NAS is named Diskstation and it’s IP is…back to the wiki.

I then went on to edit auto.nfs.shares as per the wiki

/mnt/<share1> IP of server1</path/to/share1>

and tried /mnt/pvr and /mnt/pvr, restarted autofs and tested by typing ls -lah /mnt/ and ls -lah /mnt/diskstation/pvr and many other variations. It keeps coming back with ls: cannot access '/mnt/diskstation/pvr': No such file or directory or instead of diskstation it would be the IP address, depending on what I edited the auto.nfs.shares file to be.

Sorry, I’m finding this all very confusing. To dissect the /mnt/<share1> IP of server1</path/to/share1>:
I take mnt to be the command that is saying let’s make a new connection to somewhere then
<share1> would be what are we going to call this mount
<IP of server:> is fairly self explanatory and then
</path/to/share1> is the path on the server, which in my case ought to be /video/PVR or diskstation/video/pvr or - I tried them all and none seemed to work.

I didn’t think it would be this hard to just point to a folder on the NAS and say “put the recordings there”.


Could you please issue this command on the vero4k from the commandline and provide the output:

showmount -e

Thanks Tom.

auto.nfs.shares file has this line in it: /mnt/pvr

and this is the output of showmount

Export list for
/volume2/video *
/volume2/music (everyone)

FYI, is the Vero.


Please try the following in /etc/auto.nfs.shares:


Thanks Tom.

1 Like

Your file /etc/auto.nfs.shares should contain:


The letters are case-sensitive. Sorry, currently writing from smartphone, hope all is correct.

have exactly that, same case and everything. Restart autofs, then the ls command end up with this:
ls: cannot access '/mnt/diskstation/pvr': No such file or directory

There is obviously a translation of the IP address to the name “diskstation” since the /etc/auto.nfs.shares file uses the IP and the ls commands spits out the name.


Whats the output of:

ls /mnt/pvr

Also could you please post the current contents of your /etc/auto.nfs.shares ?

Thanks Tom.

output of: ls /mnt/pvr
osmc@Vero4k:~$ ls /mnt/pvr
ls: cannot open directory '/mnt/pvr': Permission denied

Also could you please post the current contents of your /etc/auto.nfs.shares ?

file: /etc/auto.nfs.shares
contents: /mnt/pvr


Ok so looks like a permissions issue here, either on the vero or on the nas; I suspect the latter. I think attempting to mount the share manually will give us more details, please issue the following on the vero commandline:

sudo mount -v -t nfs /mnt/pvr

and post the output here.

Thanks Tom.

This what I get

mount.nfs: timeout set for Fri Oct 26 15:34:42 2018
mount.nfs: trying text-based options ‘vers=4.2,addr=,clientaddr=’
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options ‘vers=4.1,addr=,clientaddr=’


What happens now if you try to ls /mnt/pvr now?

Also whats the output of:

mount|grep pvr

Thanks Tom.

ls /mnt/pvr results in ls: cannot open directory '/mnt/pvr': Permission denied

mount|grep pvr gives us

/etc/auto.nfs.shares on /mnt/pvr type autofs (rw,relatime,fd=6,pgrp=672,timeout=15,minproto=5,maxproto=5,direct) on /mnt/pvr type nfs4 (rw,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr=


Ok confirms the share is mounting, but there is indeed a permissions issues. First is to check the vero4k side, as this will be the easiest to fix:

Please provide the output of:

ls -lah /mnt

then issue: ls /mnt/pvr

and then provide the output of (again):

ls -lah /mnt

Thanks Tom.