Vero4k won't start, Red led on

#1

Hi there.
My Vero4k shows only red led, no output, no ssh connection possible.
It was working fine for several months, no changes I could think of.
At some point I just turned on the TV and receiver and no signal. I saw the red light. I checked all connections, unplugged the PSU, plugged it back a few minutes later. No change.
I looked at other topics here.
Could it be a faulty PSU? Is there any way to check?

#2

Try a reinstall.

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

#3

This same issue just happened to me as well, incredibly frustrating, especially if I cant recover my settings or watched statuses. I was about to start a thread and thought it more sensible to post here.

Is there no way to back-up if a reinstall is needed? I’ve noticed in other threads it may be the AC adapter?

EDIT: Still a red light when attempting reinstall.

#4

It could be the power supply. Start a support ticket with your order number

You can also power the device with a USB cable with the mains disconnected.

Cheers

Sam

#5

Can you explain how to use a USB cable to power the vero? All my usb power cables are from phones with USB to micro usb or USB-C.

EDIT: tried with the following USB-C ac adapter:

No luck on either USB ports

#6

Did you disconnect the Vero power supply? And did you still get the red light?

#7

Nothing connected besides the AC unit in the picture and no light what so ever.

#8

I assume that it was plugged in? :grin: Do as Sam suggested and open a support ticket.

#9

Indeed it was, I’ll proceed with a ticket.

#10

Just a thought… But have you tried to use that A-C cable to charge a C device? Or just use it to transfer data?

#11

Cable works fine, was able to do both. Even tried a different AC adapter with the cable and a power bank as well and still the same result.

#12

And you did try both USB ports on the Vero. Definitely open a support ticket. And include this information.

#13

Yes, I did try both, I mentioned that previously.

#14

Hey there. I finally got some time and found a cable to try to power it through USB.
I had to go with several adapters, but once I did, the Vero did turn on, blue led.
I turned on TV and receiver and I have video output of HDMI, Kodi launched.
Everything’s fine except I probably don’t get enough power from the USB plug, everytime I send an IR commanrd (through Logitech Harmony hub blasters), the HDMI output blacks out for 1 second.

Anyway, I’ll open a support ticket right now.

#15

I just used my USB-C to USB cable in my PC and it turned on and is working fine now.

#16

Then the power supply is just an issue. Raise a warranty support request via the ticket system and mention your order number

Cheers

Sam

#17

Power supply has been shipped out to me. Thanks everyone for the help.

1 Like
#19

I have the same problem with my Vero 4k+. It doesn’t boot and no connection with ssh. sometimes when i plug the ac in, the red light shows all the time, when i try i again, plug off and in again no red led light is on.

i tried another ac with 5v alreday and i have the same problem.

#20

Start a support ticket if you are having problems.

#21

sorry for the dumb question… where i can open a support ticket?