Vero4k won't start, Red led on

Usually just a few hours

Cheers

Sam

hmm ok. still wait since yesterday evening
may u checky ticket please Ticket no. #310930

I have re-sent the response.

ok thanks. i just answered already

As the goods are second hand and haven’t been purchased new from us or one of our resellers, I would suggest contacting the seller.

Sam

i answered in my ticket. maybe you can help me in goodwill. it was a new vero that i bought but the seller was a private person :frowning:

I was about to start a new topic, as I cannot seem to find the support email address anymore, but this post was suggested.

Last night, I heard an audible “pop” then a few minutes later, our Vero 4K turned off and the front LED remained red no matter what. I tried pulling the plug, waiting a minute or two, then reconnecting but it was just showing the red LED and nothing on the screen.

I then used the “contact us” section on here, but I’m unsure if this is actually for support or general queries as I never received a reply (for support, I would normally expect a ticket number as an automated reply) so just wanted to follow-up in here.

I noticed above that the Vero 4K can be powered via the USB ports - fortunately I had a spare USB-A to USB-A cable that came with a HDD caddy I bought, and when I used this via our USB wall socket, voila - the Vero 4K came back to life, blue LED and it worked just fine.

I therefore suspect that the audible “pop” was the PSU blowing, so just wanted to find out what my options are.

At the moment, fortunately the USB-A to USB-A cable means we can still use the Vero 4K, but the lead is for a HDD caddy which I often use and I would prefer to use the designated PSU if possible.

Problem is, our Vero 4K was bought around April 2017, although that was replaced in December 2017 due to a faulty LED that kept flickering.

Happy to email support, but I don’t know what the address is (only one I have is from when @sam_nazarko replied to our issue in December 2017, which seems to be his email address and not a support one) - any advice?

support@osmc.tv

1 Like

Thanks, have emailed.

Your email was received and we issued a response. The device is out of warranty but we have sent a new power supply. I would advise making some changes to your setup

Sam

1 Like

Ok, thanks. Sorry for the deluge in that case, but I couldn’t be sure if the contact form (Contact - OSMC) was working for support or not.

Your email was received and we issued a response.

I haven’t received anything yet @sam_nazarko? Just checked my spam folder too, but nothing?

The device is out of warranty but we have sent a new power supply.

Thanks! That’s fantastic, appreciate that.

I would advise making some changes to your setup

Why would you suggest that? My setup is pretty standard - Vero 4K powered by the PSU supplied (until last night), with the USB remote dongle connected, and a Mote light stick connected via the other USB (and the Mote is also supplemented with an additional USB power source to prevent it drawing too much from the Vero)…

I have sent the message again.

Received - thanks @sam_nazarko.

I didn’t realise that using the PSU in an extension lead was an issue? It might be worth making that more prominent if this is the case, as I’m pretty sure that a number of people who have their Vero 4K at their main hub of the TV, will have multiple devices connected and likely via an extension lead…

Good to know though, I’ll make sure that we move some of the plugs around to accommodate this.

Hello,

it seems that i have the same problem with my vero 4k. I measured the voltage of the PSU with 5,4V but that says nothing about a stable ampere out.
Unfortunately i don’t have another PSU with this parameters. So has anyone recommendations which PSU is fine for the Vero 4k?

Well as a quick test you could use a USB A-A Cable to power the Vero.

Also find the details for the Power Supply.
Some time ago @sam_nazarko provided some links how to order them within the osmc shop, see his post

https://discourse.osmc.tv/t/vero4k-power-supply/87080/5

Other way would be to get one somewhere else, specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

You mean plugin in to the USB-IN Ports used for RC-receiver i.e.?`

I havn’t a USB-A-A but i tested a USB-C-A cable. But absolut nothing. Tomorrow a new PSU will arrive. I will see if that was the problem.
Actually i opened the PSU but none of the capacitors looked bad.

Correct

I haven’t tried a USB C-A Cable, not sure if it would work the same way. Did a quick read up and I don’t think that works with out some electronics.

You posted in a thread that is named Vero4k won't start, Red led on so are you having the Red led on or not?

Hello,

Connected with USB-A it started without anything, no LED…

But my new PSU came today. Now the Vero is again working like charme :smiling_face_with_three_hearts:

For everyone who is looking for a replacement, i took this one https://www.amazon.de/dp/B01I1LRCXW
It is a little less price intense and faster than shipping from GBR.

Thanks

1 Like

Glad to hear this but OD/ID are not correct from the top of my head.

This could cause problems.

Amazon Link
Steckerdurchmesser außen/innen : 5,5*2,5mm Stecker

OSMC Specifications
5V, 2A center positive, 5.5mm OD; 2.1mm ID

@Bond246 might be that the 0.5mm difference will give you connectivity issues over time.