Vero4k x265 video stuttering / buffering issues

Very recently (past 1-2 weeks) all x265 video has started stuttering. h264 video is not stuttering.

I first noticed the stuttering on newly added content but even when I try watching old files, which I’ve had for years and watched many times, it stutters too.

In addition the stuttering, it’s been occasionally freezing during playback of h264 files where I can’t do anything, ssh stops responding and I’m forced to pull the power and reboot.

The stuttering did not start due to any of my settings being changed (it’s probably been years since the last time I changed any video settings). However, since the stuttering occurred, I’ve attempted to adjust my settings to see if I could resolve the issue so it’s possible the settings are no longer how they were or how they should be.

I’ve seen that, in the past, others have had similar issues and I checked to see what my settings were for Adjust display refresh rate… it’s set to On start / stop. This was definitely how I had it set before the stuttering started happening.

After the stuttering first started occurring, I tried to resolve it by testing with Sync playback to display enabled and with it disabled and now I’m not sure whether it was enabled or disabled when the stuttering first started. Currently it’s disabled.

I enabled debug logging and tried to play the first episode of The Wire (which I’ve had for years and which I’ve watched several times). The stuttering started immediately and as soon as the dialogue started it was obvious that it was out of sync.

Here are the logs:

Good Morning,

Looks like there maybe some failed updates. Please could you provide the output of:

sudo apt-get update && sudo apt-get dist-upgrade.

Thanks Tom.

Here’s the output:


please try:

sudo apt-get install --reinstall vero364-image-4.9.113-64-osmc:arm64

If that fails, I suspect you may need to do a fresh install.

Regards Tom.

osmc@vero:~$ sudo apt-get install --reinstall vero364-image-4.9.113-64-osmc:arm64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for vero364-image-4.9.113-64-osmc:arm64

So does this mean a complete reinstall is required?


Just tried that command on my vero4k and it work. So yes I believe you need to do a complete reinstall.

Thanks Tom.



I don’t know if it’s relevant but I had a similar problem with playing back many H.265 and some H.264 files that I just solved. The video looked like it was running in slow motion, frame skips increased in bursts and aq went down to zero then the video froze and everything rebuffered.

I tried manually updating with SSH, that completed successfully and didn’t make any difference.

I have a 4k TV and I had the menu resolution set to 2160p. When I was logging, the OSD shows I was only getting 8FPS in the GUI. I turned the GUI resolution down to 1080p. My Vero still plays 4k files at 4k but all the performance problems suddenly went away.

The OP posted logs. They show the device is using recommended settings, including a 1080p UI and refresh rate switching.

1 Like

This is the frame rate of the user OSD window and is intentionally limited. It is not the playback frame rate.