VeroV remote stopped working


My Vero V remote stopped working after a reboot. When attemping to repair using OK+Home for a couple of seconds a blue light starts shining for a while, but no response from the unit. The user interface looks normal after startup (in my case, the Retrospect plugin starting).

An attached USB keyboard is also not responsive.

Happily I could log in using SSH to grab logs with grab-logs -A:

Please help, since the WAF is plummeting right now…

Kind regards

Do you have any USB devices plugged in other that that keyboard?

No, no other devices. Just HDMI output and an ethernet cable.

Is the USB keyboard plugged in to the USB3 port or the USB2 port?



I’ve tried both ports and two different USB keyboards.

The USB3 and USB2 ports are wired completely differently via two separate interfaces.

Could be a hardware issue or a power supply issue.
Do you have a USB-A to USB-A cable or another 5V, 2A PSU at hand?

We will get this solved promptly.

I’ve also tried renaming the ~/.kodi directory. After a reboot the device shows the default Kodi page (not the Retrospect app), but keyboard or remote still not working.

I still have my old Vero 4k lying around, would its power supply suffice?


Remote still not working with the power supply from the 4k.

Then I suggest you contact with order details and we initiate the RMA process.
I assume you also checked that other USB devices are not working either with the alternative PSU.

Yes, USB keyboard also not working the the other PSU. I’ll contact sales.

Thank you for your quick response!

You’re welcome – have a good evening

I’m still a bit in doubt if this is really a hardware issue - the system journal shows this when I attach a usb keyboard:

Jan 04 01:02:39 verov kernel: usb 1-2: new low-speed USB device number 7 using xhci-hcd
Jan 04 01:02:39 verov kernel: usb 1-2: New USB device found, idVendor=046a, idProduct=0023
Jan 04 01:02:39 verov kernel: usb 1-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0

and lsusb also shows the usb keyboard:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 046a:0023 Cherry GmbH Keyboard
Bus 001 Device 002: ID 1a40:0801 Terminus Technology Inc. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Moreover, it seems like there was a kernel upgrade recently, this night’s reboot might have been the first with the new kernel:

root@verov:/home/osmc# ls -l /lib/modules/
total 8
drwxr-xr-x 3 root root 4096 Aug  7 17:22 4.9.269-35-osmc
drwxr-xr-x 3 root root 4096 Dec 28 16:10 4.9.269-44-osmc

Is there a way on the Vero V to boot using the previous kernel version?

If you are convinced it actually is a hardware issue, I’ll stop nagging you. Just trying to prevent a possible unnecessary RMA.

Suggest you do a clean reinstall with the August Image. If that is working fine first try the update to december before setting up the rest of the system.

Just tried a clean install of the 2023.08-1 image. Installation via USB went well, the device then shows the screen to pair the OSMC remote, but the remote won’t pair. I’ve tried attaching a USB keyboard again, which also isn’t recognized.
What I hadn’t tried before is using the remote from my old Vero 4k+, but that remote can’t be paired either.
It really seems the device is bust.