Very frequent crashes

Pi1 B+ with official Pi power supply, tried with two separate SD cards

I’m getting very frequent crashes on:
Editing and system settings e.g device name, audio output 50% of the time
Scanning for new content on external, powered HD
Navigating menus whilst it nis playing music over airplay

Edit: it usually just freezes indefinitely, but more recently, it will freeze, show a square sad face icon and then reboot quickly

re: edit
the below crash occured when i tried to enable upnp

the below crash occurred when i tried to scan a folder on an external hard drive for new films

and again

SOLUTION: going into the config.txt file and undoing the default overclock set by OSMC, and setting them back to the Pi defaults of arm: 700, core/gpu: 250, sdram: 400 fixed all instability

I edited your post, please use



Crashes and freezes as this is usually a power/voltage problem or overclocking.
Do you see a coloured square in the right corner at any time?

Also, never cut logs, always proved full logs.

1 Like

Bring the clock speeds down, I don’t know why by default so many Raspberry OS’s come with the clock speeds set high. Mine crashes constantly like yours at the default 850Mhz that comes with OSMC, drop it back to 700Mhz the Pi default and see how you go.

Im afraid not, it is certainly acting like a power problem. But I’m using the official power supply and no coloured square.

Yeah it reminds me of an overclocking instability, how to I undo the overclocking, do I only have to reduce the clock speed or is there anything else I need to change?

Reduce the clock speed, but you could just delete any clocking settings in config.txt and it will be reduced to default.

Default values are arm 700, core/gpu 250, sdram 400.

1 Like

In kodi, you can go to Programs > OSMC settings > Overclock.
In there it says what the setting is and what you can change it to, from memory I dropped mine back to Pi Defaults.
BTW the ‘Normal’ setting is Overclocked not Pi defaults.

1 Like

Undoing the over clock by editing the config file worked!!! :slight_smile:

I have the same problems as you have done to cancel the clock above OSMC ? can you help me specifically
step by step?!

can someone please post the exact syntax needed in order to make OSMC use pi default clock settings (Default values are arm 700, core/gpu 250, sdram 400)

I need to be able to make this change via SSH and not the Kodi’s GUI. thanks :smile:

my current cmdline.txt file:

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2

You need to be looking at config.txt, not cmdline.

thanks for the quick reply, sorry pasted the wrong file info, can you please let me know what the following would need to be changed to?

gpu_mem_1024=256 start_x=1 sdtv_aspect=0 hdmi_ignore_cec_init=1 disable_overscan=1


1 Like

would this need to be appended to the current file or completely replaced?

This is just the “normal” performance values (for the RPi2) you had asked for. They obviously need to be appended