Video breaks when hyperion is running

If hyperion is running the HDMI signal is broken periodically, this first started after the October update.
I am quite frustrated since I am investigating this the whole day.

This is even true if the video is paused. In the menu everything works fine.

This sounds like a power supply issue. How are you powering your Pi?

I am powering the Raspberry with a 2A power supply and the LEDs with a separate one. Power isn’t an issue, since before the last update I run the Pi2 from the power of the TV and everything worked fine. But after the update I had to move back to the external power supply.

Power supplies can degrade over time.

If the CPU usage is low, then this indicates a power problem. Otherwise a debug log will be a good place to start. To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us…


I tried another power supply. But nothing changed. I increased the GPU Memory to the max and used config_hdmi_boost=7.

Here is the log file:

  • I first started with both accelerations.
  • After that I disabled OMXPlayer.
  • The third time I disabled hyperion and after some time
    started it.

Just noticed that I didn’t had the debugging enabled.

Here is another one with debugging

  • I first started with both accelerations, no hyperion at start and than activated it
  • After that I disabled OMXPlayer with hyperion actived.
  • The third time I disabled hyperion

Just did a fresh install on a new SD Card, and I am experiencing the exact same issue. I installed the latest (2015.10-1) version onto the sd card. I am getting these HDMI issues on any media i am playing. I used a new 2A power supply.

I even tried with an older installation and the same thing is happening. I think this is a problem related to hyperion.

Same here - after about september/october update hyperion starts to crash my RaspberryPi 2 on video playback.

Power supply is good. Tried without the led’s attached and different PSU - same results.

It however does work up to the point the video playback starts.

I tried compiling hyperion from scratch, but no help - it still crashes. So right now I disable hyperion daemon after boot and all is fine.

I tried nearly everything and found that everything is working fine if the width and height of the framegrabber is a power of 2 and width and height are exactly the same.

This is my current configuration which is working fine without a crash:

	"framegrabber" :
		"width" : 64,
		"height" : 64,
		"frequency_Hz" : 30

I had 32x32 resolution with 10Hz update. Switched to 64x64 and 30Hz and all is good now indeed.

Yeah 32x32 isn’t working anymore.

Same issue here, tried 64x64 10/30; 32x32,10/30;
But it still crashes at the video.
Any suggestions?