Video calibration and resolution settings are getting reset after switching TV off→on

#1

Repro:

  • have following setup: Vero 4k+ connected to the Yamaha YSP-2700’s HDMI input and LG OLED55B8 connected to the YSP’s HDMI out
  • calibrate video area
  • switch off the TV with the TV’s remote (switches off the YSP as well)
  • switch the TV back on

Expected: the video calibration settings are preserved
Instead: video calibration settings are reset (along with the output resolution)

Logs: http://paste.osmc.tv/usesusiqap

#2

Resolution should be set to 1080p and you should not need to use video calibration (I assume you mean overscan). Just configure the TV for “just scan” or “1:1”
While it doesn’t address the issue you are discribing it at least makes the steps not needed

#3

Calibration settings are for every resolution. This may be the issue

#4

Uh, I’m not sure. It’s Preferences → System → Display → Video Calibration (or something like that; it’s the last item in the list on the right before “Reset…”).

I actually did, even before Vero, doesn’t help really — the UI looks like the overscan is in effect already:

. That’s why I needed to calibrate overscan in the first place.

#5

Is there any other information I could provide to triage the issue?

#6

Modern TVs should not need Kodi calibration to resolve overscan issues. You should be testing the different zoom or aspect ratio settings on the TV to find the correct setting as @fzinken stated earlier. Spending big bucks on a television and then using Kodi’s less than stellar scaler can only result in less than optimal video quality.

#7

Well, the TV’s aspect ratio is set to “Original” (which probably means 1:1) and I’m politely refusing to try anything else.

#9

Well, that seems a pretty ignorant thing to do… …but your TVs manual seems to indicate that a Just Scan mode is available.

  1. Aspect Ratio (Command: k c)
    (Main Picture Size)
    ► To adjust the screen format. (Main picture format)
    You can also adjust the screen format using the
    Aspect Ratio in the Q.MENU. or PICTURE menu.

Transmission [k][c][Set ID][Data][Cr]

Data 01 : Normal screen
(4:3)
02 : Wide screen
(16:9)
04 : Zoom
05 : Zoom 2
(Latin America
except Colombia
Only)
06 : Set by Program/
Original 07 : 14:9
(Europe, Colombia, Mid-East,
Asia except South Korea and
Japan)
09 : * Just Scan
0B : Full Wide
(Europe, Colombia, Mid
East, Asia except South
Korea and Japan)
10 to 1F : Cinema Zoom 1 to 16
0c : 21:9 (Depending on model)

Ack [c][Set ID][OK/NG][Data]

  • Using the PC input, you select either 16:9 or 4:3
    screen aspect ratio.
  • In DTV/HDMI/Component mode (high-definition),
    Just Scan is available.
  • Full wide mode may work differently based on
    model and is supported for DTV fully, and ATV,
    AV partially
#10

I had the same, “solved” it by Skin and put zoom to minus 4%. Then the gui got right.

based on @ActionA i looked into my tv (Samsung Q9FN) and found within picture settings, just scan was off. Turning it on, the screen got bigger and i could turn zoom off.

But putting the setting on tv to auto (which seem to me better, because I’m only using HDMI 4 as input on tv, because AVR is in between) , that didn’t do anything and the screen got same as with off, so then zoom was a better option.

I’m not sure if i can manage just scan via the HDMI settings on my AVR.

#11

Thank you for pointing out. It was an ignorant thing indeed. I’ve found “Just Scan” in general settings were buried in full “display settings” menu while i’ve assumed quick settings are identical to them. Forcing “Just Scan” to “On” did resolve the issue. Thank you for the tip again.

#12

Glad to have helped you improve things for the better! Enjoy!

1 Like