Video calibration is reset by display power cycle. (subtitle position)

I run a projector on a 2.35:1 screen and have therefore used the subtitle position in the video calibration to set the location, and used fixed subtitle position to make sure the subs were in the frame. Bottom of video is useless when playing a remux.

The problem is the calibration is reset if I power cycle either my projector (JVC DLA-N7) or my AVR (Marantz AV7704). If I set my AVR to not pass through in standby, it sticks, but the problem remains as a power cycle of the projector still causes a reset.

I have tried caching the EDID in the disp_cap file, to no avail. (sudo cp /sys/class/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/userdata/disp_cap

Here is my debug log of a display calibration and subsequent power cycle of the display.

Is there a way I can make the calibration stick?

As a partial work-around you could use Key Map Editor to map two keys on the remote to move the subtitle position up and down - I use the volume control keys. That gives you a way of adjusting subtitle position during playback without going into the video calibration settings.

Good suggestion, but I’d like for my setup to be as easy as possible for guests and the like to use. It has worked perfectly for me in the past, so it really ought to work.

Please use the log uploader in My OSMC or grab-logs -A so we can get the full picture.

You could try re-starting Kodi after setting the subtitle position (Power->Exit) to make sure the settings are saved to guisettings.xml.


Edit: I didn’t specify what I did… facepalm

  • Boot
  • Change resolution to 1080p60
  • Change subtitle position to 952 in video calibration
  • Return to main menu
  • Power cycle AVR
  • Check video calibration (it was reset)

You missed out ‘restart Kodi’ from your list. Did you do that? Ideal sequence:

  • set resolution to 1080p60
  • set subtitle position
  • grab logs
  • restart Kodi
  • grab logs
  • power cycle AVR
  • grab logs

I rebooted after enabling debug, but not after resolution change. I can do that in a mo

Don’t reboot - just restart Kodi (Power->Exit).

Here you go.

OK, thanks. That’s all working as expected - the setting stays at 952 as you can see in guisettings.xml. I don’t think the AVR power cycle is causing the ‘loss of memory’.

            <description>1920x1080 @ 60.00 - Full Screen</description>

You need to be aware that Kodi stores the subtitle location for each resolution and refreshrate. You have set the location for 1080p60 but not for anything else, including 1080p59.94 which is likely what your videos will play at. Why Team Kodi think they should be different I’ve no idea.

I went to check the calibration after the whole sequence and it was reset to 1042. I don’t know why that is not reflected in guisettings. If I check guisettings now, it is reset to 1042, so not quite working as expected.

I am aware I need to calibrate all resolution combinations, but for the sake of this test I only did 1080p60.

I have done the calibration tens of times and every time it is reset to default after I power cycle my projector or AVR.

            <description>1920x1080 @ 60.00 - Full Screen</description>

I’ll do the whole sequence again later, and include a Kodi restart after the AVR power cycle

This is all very odd. So even after you have 952 in guisettings.xml, an AVR power cycle re-sets it?

Have you searched/asked on the Kodi forum about this?

I think I have narrowed down when it happens.
If I power cycle after a calibration, the guisettings are not updated, but if I then open the video calibration the position is reset and guisettings is updated.
Similarly if I power cycle after a calibration and play a movie, the subtitles are back at the default value (1042), but the guisettings still reflect 952. If I then restart Kodi the guisettings are loaded again and the subtitles return to 952. Only if I open video calibration is the change committed to guisettings.
It seems the subtitle position is reset in RAM but not committed before I open video calibration.

I have verified with the 2160p24 resolutions this time, as they are the ones I use. The subtitles shift position after a power cycle.

I uploaded a log after an AVR power cycle and after opening the video calibration. These logs still use 1080p60 for testing
After AVR power cycle (the guisettings remain at 952):
after opening video calibration (guisettings are reset):

I have not yet asked on the Kodi forum, but searched far and wide.

Thanks for the research. I’m struggling to reproduce this behaviour and must be missing something. Can you list the exact steps you take after setting the subtitle position to cause the setting to be re-set (to default)?

I’ll try. Though I’m thinking it may be something specific to my setup or projector.

This is my experience so far:

  1. Calibrate and play a movie. The subtitle position is correct and the setting is reflected in guisettings (952).
  2. Power cycle projector, AVR or both.
  3. Play the same movie that had the correct sub position before the power cycle. The subs have moved to the default position (1042), but the change is not reflected in the guisettings as they still show 952.
  4. Go to video calibration to check finding the default is back (1042). The action of opening video calibration commits the change to guisettings. I can see this happening live by having the guisettings.xml open in bbedit on my mac.

if I, instead of opening video calibration, restart Kodi, the default is never committed to guisettings, and the calibrated settings (952) are reloaded, restoring the intended sub position. That is, until the next power cycle.

Was that clear enough? It is a very strange bug, and I fear it has to do with some hardware specifics in my setup. Tomorrow I’ll try connecting a TV to my AVR instead to test if the problem persists.

By the way, thanks for your help so far.

I think I’ve got it now, thanks.

It’s not just you, my setup does this also. Every time I turn on my Denon and Epson 5050 the video calibration is reset back to 0,0. I’ve set it for each resolution but it never sticks. Unfortunately I’ve never seen this topic advance, people can’t reproduce. I wonder if the AVR is sending some kind of weird edid when the projector or AVR is off that causes it to reset.

Good to hear I’m not alone. I’m unsure when the problem arose for me, but I remember it not being an issue with my old libreelec setup and old projector (JVC DLA-X7)

I guess if there was a way to change the default the problem would be remedied for the subtitles. But I think that it’s baked into the source code for Kodi.