Video dropout


I’ve had some problems with video dropping out for a few seconds with some files. Log at File name bumblebee 2018 video drops out after around 50 secs. Please help if possible.

It’s not a debug log but looks like you have some connectivity issues with your NAS:

20:03:07.645 T:3493851904 ERROR: NFS: Failed to mount nfs share: (nfs_mount_async failed)

Oh I thought I’d provided a debug log. What do I need to do to provide one? Also what should I try to fix the NAS? Is there an easy way to factory reset?

Yes — you can easily reinstall osmc if you’d like, but I’m not sure that would solve the issue.

Ok so how would i provide a log? Last time I enabled debug logging, reproduced the issue, then went to the log uploader. What do I need to do different please?

That’s all you need to do; but debug logging wasn’t enabled here

You probably need to enable “Wait for network” on the MyOSMC add-on. That will at least mean that Kodi doesn’t start too early.

Ok, is this a correct log ?

Tried enabling wait for network, makes no difference.
I put the file on a usb harddrive and the video dropout happened at exactly the same place. I’m pretty sure the video is losing sync for some reason.

I do remember a few years ago on this build, the sync playback to display toggle was broken, could this still be the case?
Thanks in advance

kind regards


I suggest trying with sync to display disabled.

You have enabled audio passthrough options, having sync to display enabled; affectively disables these.

Also you have adjust refresh rate set to start & stop, should be either using adjustre fresh rate or sync to display, not both.

Thanks Tom.

So I’ve found out turning off adjust refresh rate stops the video dropouts. But then I would need to change refresh rate manually depending on video so that not a great fix. Is there anyway I can get it the switch to the correct frame rate without causing video dropouts?

Does the issue occur if you play the file from local storage?


Whats happens if you set adjust refresh rate to start & stop and also disable sync to display?

Thanks Tom.


Tried the update today and the issue remains. Toggling sync playback to display makes no difference. I’ve tried playing the file from a usb harddrive as well but the problem is still there. Can anyone tell anything from my log? I was thinking maybe the sync playback toggle is broken or should I try hdmi clock limit in the config?

I’m kinda surprised more people aren’t having the issue. My dad’s Vero has the same problem and his setup is completely different to mine, at a separate location.

Is he having problems with the same files? I see this with some DVDs that I’ve ripped, most noticeable is Deep Space 9. Every single episode does it. They are poorly mastered DVDs; the refresh rate seems to switch, most often right after the opening titles play.

Since you did the update, new logs may help.

Not really sure as we have a differt video library. I could understand it the refresh rate of the video changes but it doesn’t. It happens with 24p blu ray rips. I’ve also seen it happen when I playback my own 60p GoPro footage I made in Premier Pro. I’m pretty sure it’s a bug where it video losing sync. Can anyone supply any suggestions from my log?