Video-file download via TVHeadend-GUI interrupts

When trying to download a recorded video-file via TVHeadend-GUI the download stops at a certain percent. After rebooting the PI the download works. Here is a log file:

Problem still persists. No idea? Something wrong with the log-file?

So, for me it looks again like one of the Raspberry 3B + network issues with current LAN78XX driver, see also SFTP stalls when transferring files from NTFS drive - #35 by JimKnopf and the mentioned link.

Could you just for tests give a Wifi connection a try whether this works as expected?

Same Problem with wireless. Stops at 3%.

Only idea I have at the moment is the power consumption:
You have Bluray drive, an external USB hdd and some Logitech dongle connected to the 3B+.

If you have a self-powered hub at hand, try to put in between the hdd and the Pi. And test again.

Other ideas are welcome.

Apart from the dongle for mouse and keyboard, all USB devices are already attached to a self-powered hub.

Installation from scretch solved the problem.

Unfortunately it didn’t. After a few good downloads the problem is back again. I changed cabeling, bypassed switch, tried wired static and wired DHCP, tried WiFi: Problem stays. Next step is changing RasPi.

I’m using my old Pi 3 Model B and the Problem is gone. Must be some Problems with the B+ Ethernet interface.


You may find things more stable if you reduce the network speed to 100, rather than gigabit:

Thanks Tom.

That did it. Thanks. RP 3B+ pseudo-GBit-Adapter is crab.

1 Like

Finally I found the real reason and it’s not a Network problem: I record on a external HD. It is connected trough a powered USB hub. There seems to be a Problem with the power consumption. After connecting the HD directly to the Raspi (powered by a 2.5 A power supply) everything runs smooth. The affected power supply only had 0.4 A. Now I bought one with 2 A and it works also through hub.

1 Like