Video freezing while audio still plays on Vero 4K


I just received my Vero 4K for Christmas and its great! However, I have a series in 4K I’m trying to watch and the video either buffers for a second, freezes, goes to a black screen or the hdmi stops responding all together and I get a no input on my TV until I press the stop button on my remote. The audio works fine. The videos are stored on a NAS with both the NAS and Vero on the same switch. The NAS is mounted via fstab and its an NFS mount. I have tried to play the same video on my Mac over the network and it works fine so I’m sure the media itself is alright.

Here are the logs:

any ideas?

I should mention that I can play other 4K movies perfectly fine.
The movies are around 60GB around 120 Minutes which work great.
where the episode I’m trying to watch are around 5GB for 60 Minutes

Provide mediainfo of the file giving problem
Please see the mediainfo section in How to submit a useful support request - General - OSMC

Sorry, here is the MediaInfo:

Thanks, I hope @sam_nazarko has an idea

1 Like

Can you try copying the file to the V4K storage and playing it without the network being a factor?

Just tried that, same thing still occurs, shall I post updated logs?

Yes, but they would seem to indicate a problem with the file itself.

the file plays fine on my Mac though with no issues locally and over the network but here are the logs:

Is the Mac actually decoding it in hardware though?

Can you send a 30 second sample of the file?

Honestly, I have no idea. How do I check? And how do I make a sample?