Video is slower than audio on Kodi

Hi, some of my files have the video slower than the audio when played by Kodi.
I tried to turn off acceleration and I also put the “refresh” option to Always.
The result is better, it’s not slowed anymore but the video is weird… Like if it was in 8fps or with missing frames.

I use a NAS with SMB folders, I tried with USB stick. Same behavior.
Video is played fine on VLC, Kodi (Windows), iPad, Apple TV and DuneHD.

How can I fix that without re-encoding more than 500 files? :woozy_face:
I really don’t get why it’s only few files, not all of them. It’s not related to my connection, those files are like 6000kbps and I get read fiels up to 70Mbps with no problem

Vero 4K - OSMC 2023.06-1 - Kodi 20.1
Here is the NFO of the 1st file I played (x264 8bits):
Here is the NFO of the 2nd file I played (x265 10bits):
Both have video slower than audio when read on Vero 4K with Kodi.
Here is the log:

Thank you~

You have your GUI resolution set at 4K and this is disrupting the intended functioning of the whitelist. If you change your settings as prescribed below I think this will likely fix your issue. If there is still an issue then please post full logs uploaded from the My OSMC add-on as this will give us a more complete picture of exactly how you have your device configured.

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always or On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Probably a silly question - but why isn’t the GUI limited to a maximum of 1080p in the settings, to prevent this common issue?

1 Like

Not silly, I think the question is legit, but I don’t really have an answer for you. I’ve just assumed there was some technical limitation or an edge case where exposing this option was beneficial. Did this fix the issue you were experiencing?

I have never had this problem myself (as I read this advice in the forum years ago before buying my 1st Vero) but see it reported as a potential solution so often I just wondered if preventing the GUI going to 4k would save a lot of time and trouble on the forum?

There is a big warning message if you try and change the UI to 4K advising against that. That should really be sufficient.

1 Like

I knew it was Kodi’s fault… On Kodi’s server, people told me “It’s due to OSMC blah-blah”

I did:
Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) (It already was empty, I didn’t touch it)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Now the 1080p, x264, 8bit file is played correctly! The video is now synced with audio!
Thank you for that! :star_struck:

But… For the 1080p, x265, 10bits file… Still the same result. :frowning_face:
You can see the CPU-KODI goes up to 410% for this file…

Any idea why? Is it because of the 10bits?

Bad link on the log but from the mediainfo I can see the issue is that your not trying to play a 10 bit x265 file, which shouldn’t be an issue, but rather that is a 10 bit h.264 file, aka hi10p which is not a supported format. There is no hardware acceleration for that format in either the Vero or any of the Raspberry Pi’s and being CPU bound on a file that is intentionally complex to reduce file size is challenging to impossible on a lot of hardware. If it was me I would just transcode the hi10p stuff with Handbrake. Once you familiarize yourself with how the batch processing works it can be done fairly efficiently as far as the time you have to spend manually interacting the the software to setup the batch jobs.

1 Like

Oh yeah you’re right, it’s fine I’ll take another release then, lazy to encode (I use StaxRip)
At least, now I can watch all the Drag Race series on my Vero 4K :hugs:

Because, for some reasons, it only was the Drag Race series (France, Canada, UK, …) that I couldn’t play properly.

Thank you for your precise answers! You’re so much more efficient than Kodi helpers! :hugs:

1 Like

That’s surprising - usually Hi10 is exclusive to anime. Is this a particularly old file you’re trying to play?


Yeah, the Hi10 file was an anime (Blend S) and I didn’t know 10bits wasn’s supported on x264 with Kodi.

The Drag Race files was the others files I was trying to play with video unsynced. For some reasons, only Drag Race files (from SECRETOS team) had video unsynced on Kodi with the GUI in 4K, I’ve never faced another movie, … like that

But now, everything is fine :slight_smile: I can watch Drag Race with video and audio synced together and I downloaded an x265 ver of Blend S